Flexy keeps going offline

Hello,

We have a customer that has a flexy unit that is connected to the internet via cellular and the connection keeps dropping out. Right now the unit is entirely offline, but a backup has been provided (attached).eWON Backup.zip (194.6 KB)
Ecatcher’s log here seems to show a pattern of the Ewon switching online/offline approximately every hour, with the unit coming back online just one minute after going offline.
image

My first suggestion is for them to change the following parameters, but they haven’t been able to do that at this time.
MaxCallDUR = 0 (No limit on max call duration)
CallAlloc = 0 (No hour limit on outgoing connection per week)
ClIdle = 43,200 (Connection line Idle Time, minimum 60 seconds, 86,400 seconds in a day)

Can you please look at this backup and make any other suggestions? Additionally, where can I download the backup analyzer?

Thank you.

I reviewed the event logs and real time logs.

the OPCUA communication is causing the reboots to occur. Can you try to disable the OPCUA server to see if the problems persist.

The problem points toan issue with Java code.

As for the backup Analyzer, that software is not released to the public. You will not be able to download it from any of our sites.

Kevin,

To clarify are you stating that incorrect OPCUA communications is the issue or the Java code is the issue? Or both?

image001.png

image002.png

It looks to be that the Java code is causing the OPCUA communication issue.

As stated before, i would disable the IO to check if the rebooting still occurs.

@Kevin_hms

I do not think that the Java code is causing this at this time, as it isn’t being used for at the moment (however I could be wrong). I made a few internet connection parameter changes and the flexy was working as expected and online for a handful of hours, up until the machine was powered down to be moved to a new location. Ever since this power cycle it has not worked again. I did some testing with the customer today and have found the following:

Apparent Issue:

  • Something is forcing the flexy to reboot (20314 Reboot reason: Watchdog in process opcusacom)
  • The flexy continues to reboot over and over and over again, preventing any internet connection or OPCUA communication

Temporary fix to allow flexy to go back online, but not have OPCUA communications was

  • Connect locally
  • Disable OPCUA IO Server
  • Reboot
  • Back online, no OPCUA
    In one instance, we were able to also re-enable the OPCUA client at this stage (and power cycle both the Flexy and OPCUA Server device) and communications worked again. A power cycle afterwards reintroduced the prior issue and we have not been able to keep the flexy on while OPCUA is activated since, however we have not tried power cycling the machine again as it is a considerable distance away.

The MLC device by Bosch Rexroth being used (the OPCUA Server) has a known issue where it does not have a real clock. Especially on power cycles it can be very incorrect, ranging from off by house to off by years (future and present). The customer is currently unaware if this can be disabled.

We tried messing around with the NTP clock on the Flexy, switching between various Manual and automatic settings, but nothing seemed to help. I’m not sure if there is something similar to the following link at play? NTP server sycn - #4 by tdstech

I have a few questions in addition to requesting the help for getting this problem solved. Can the duration of the watchdog timer on the Flexy that is timing out be increased? Can we somehow disable the time synchronization on the client side of the OPCUA configuration?

Attached is a newer backup of the machine.eWON Backup 210914.tar (108 KB)

Just checking in to see what progress has been made on this request? On our end, I have removed the Java files and am awaiting the end user to perform a few test for me to see if the absence of Java code makes any difference.

Unfortunately, the the backup you supplied doesn’t give me any information on the Real Time logs to pin point exactly what is going on with OPCUA. The NTP issue that you highlighted could be the problem that is causing the frequent reboots.

What is the OCUA client time stamp methodology?

Could you elaborate what you mean by OPCUA client time stamp methodology? I can ask the end user this, but would like to understand a bit more. The client is the Flexy.

Can the duration of the watchdog timer on the Flexy that is timing out be increased? Can we somehow disable the time synchronization on the client side of the OPCUA configuration, as this could potentially mitigate the issue? Do you have recommendations to try with the NTP setup on the Flexy to try and solve this issue?

The end user was able to perform some tests with the Java code completely removed, here are the findings:
If power cycled with the OPCUA enabled and running the Flexy gets into an endless rebooting loop. If the OPCUA is disabled it completes the reboot over long duration (5 minutes approximately) and then continues to work. If the OPCUA is enabled after the flexy starts communicating it works without issue until next power cycle.
This issue is consistent whether we are rebooting just the Flexy or both the Flexy and the OPCUA Server device at the same time.

Hello Nick,

I will have to escalate this issue, as the errors are not giving me detailed information.

Based off the testing, there is an issue with the start of the Flexy OPCUA Client communication with the OPCUA server. It could be the client is sending +GMT for the NTP, and the server is expecting Etc.

In the meantime, can you update the flexy to the latest version?

I have just now successfully upgraded the firmware from 14.3s0 to 14.4s1.

I have passed along your timestamp methodology question to the customer and will let you know what they say.

The end user has responded that they do not know what the timestamp methodology is.

As a reminder, the controller does not have a real time clock and we are wondering if this is part of the issue. Is there a way to turn off time synchronization with the OPCUA client on the flexy?

Hello,

No there isn’t. the Certificates need the date and time.

Have you tried manually setting the date and time on the eWOn unit?

We did try manually setting the date and time (read previous post for more info here), but we were not able to get it working that way either.