Flexy modem issues


Three weeks ago we had one of our Flexy units go off line. The only resolution was to send a tech out to the site. When they got to the site the base unit was not recognizing the modem They removed the modem, power cycle the base unit, verified the base was loaded, removed power reinstalled the modem and reran the wizards then it was working as expected. This is on a unit that had been in the file for over a year.

This week we went to do a new startup and had another Flexy unit not recognized the modem. For this unit the power cycle did nothing to get the base unit to recognize the modem. The modem is good since we tried it in another base unit. The status shows the modem is installed but there is no option to select the modem in the wizards. Also when navigating to the communication and networking the modem does not show in the web interface.

These units are all running firmware 14.2s0. Verizon modems. Basic script is stopped. IO Server disabled. Attached are some backups from the latest unit. Without and with a modem installed.

What is going on with these? Is this a manufacturing issue?

Hello Ted,

I am reviewing these back up files now.

Any update

Hello Ted,

I am not aware of any new manufactoring issue with specific SN’s.

I do see several modem errors.

As far as the new unit, i do see the modem error (Modem Error (Modem ON/OFF Failed)) wuite a bit. Also tinit modem and register Modem errors as well. Are you using a the same modem for each unit? Or seperate modem for each unit?

Can you try a different modem and see if it resolves the issue?

Same modem model for each unit.

Tried a known working modem in the bad base unit with the same result. The base unit would see the modem but not be able to use it.

Just to clear up confusion

UNIT 1: Unit with Modem that only works after power cycle
UNIT 2: Base unit that shows, but no option to use modem for internet connection.

The back up you supplied was for Unit 2, correct? If so can you pull the backup with Support files for Unit 1. I want to verify if the the Modem needs the SIB Fix or not. Also can you try a working modem in Unit 1? I want to eliminate the source of the issue for that device.

Unit 2 requires a little more research, as the modem should appear if it is detected by the Flexy unit.

UNIT 1: Unit that is installed at a customer site. It went offline and the fix to bring it back online was to remove the modem power cycle reinstall the same modem and rerun wizards. Has been working since then. Still installed at the customer site. Was included with this ticket to indicated that there may or may not be a trend with modem failures. Let’s ignore this one for now as it is working.

Unit 2: Shows the modem in the slot when viewing web interface. No option to use for internet connection

Backup was supplied.



Looks like you need to change RTEnIpFwrd to 1 on both of those units.

What does that setting do?

Is this something we need to set on all our units? We have about 100 of these out in the wild.



No, that’s the default setting.

Powered up the base unit with no modem in it. Changed the RTEnIpFwrd from 0 to a 1.

Rebooted the unit the RTEnIpFwrd setting changed back to a 0.

Powered the unit off and put a known working modem into the base powered it on. All the lights are on on the modem. The base unit USR light is solid red. System info shows the modem in slot 3. Changed RTEnIpFwrd to 1 saved it refreshed the screen and it was back to a 0.

Have you tried a factory reset? If not, I think that is the next step.

Did a factory reset four times. Each time after the reboot the USR light is solid red.

Logged into the unit and it is wiped but solid has solid red USR light.

Does this have an SD card in it? Have you tried booting it without any EXT cards or SD cards installed, without anything connected?

There is nothing installed in the base. No ext cards or sd card.

There is one last thing you can try:

  1. Download the recovery file for the Ewon (14.2 is fine)
  2. Rename .ebu file to .debu and put on SD card (FAT32)
  3. Put the SD card in the Ewon and boot holding reset button for 10 seconds, then release
  4. It will take about 10 minutes to complete

We now have another unit that is dong the same thing. This unit was last powered up in July of 2019. Tech went to install it today at a customer site and the same behavior except can not even get connected with eBuddy. Same light pattern and colors as the one we are currently working on.

Do the base units lose their mind after being powered down for x time period?

The time powered down shouldn’t matter if it’s just a matter of a couple years. It is possible for non-volatile flash memory to become corrupted over time, especially if it’s stored in a not ideal place, but this should take a lot longer than a year or two. I will check with the Ewon team to see if they have seen this before.

Downloaded the recovery file and performed the steps 1 - 4 as listed on unit 1. Power cycled the unit and after the unit powered the LEDs were all on with the USR LED solid red.

Same steps were performed with unit 2 with the same results.

Is this the one with serial number 1815-0008-21? I believe there is a hardware problem, so it should be sent for an RMA.