Flexy SD Card not reading correctly

We have a flexy in our lab that we are writing historical data to an SD card. We have been switching over from a Basic script to a Java script and we noticed the writing to the SD card quit working for both the original Basic script and the Java script. I thought it might be a problem with the SD card so I reformatted it and eventually tried a different card. Neither of those solved the issue. I had a second flexy and set it up with the same configuration and inserted one of the SD cards that was not working into it. It works fine with both the Basic script and the Java script. In doing more testing I put a different brand SD card (all are industrial SD cards) into the first flexy and the scripts seem to work fine. I have done more testing with the first cards and sometimes they will not mount other times they mount and the script writes the first time but all subsequent writes fail.

Here is the backup of the application with the supporting files.


Hello @bboozer,

Could the SD card slot be damaged or could any thing have gotten into the slot such as water or dirt? I am thinking something could have happened to the contacts in the slot. The logs show the SD card working intermittently with it being inserted and removed often.

I also see significant number of FTP connections. Are you constantly connecting over FTP? Are you leaving an FTP connection open? This could be causing the SD card to constantly be busy giving the OS issues reading and writing.