FTP file transfer peer disconnect


#1

When transferring files to the Flexy over FTP, I am noticing a consistent peer disconnect at 26.5MBs. The file I am trying to transfer is ~160MBs, but every time it disconnects at 26.5MBs, which occurs 68 seconds into the transfer. This is a very repeatable issue. Are there configuration changes that need to be made to allow for larger/longer FTP file transfers?


#2

You cannot send files of that size to a Flexy; it’s not a PC. What are you trying to do?


#4

I am using the Flexy as an FTP client/server. Our computer initiates a transfer over passive ftp directly to the Flexy’s SD card. Then the Flexy iterates through the file system, and pushes files over passive ftp to an AWS server. The goal is to use the Flexy as a gateway for remote data collection. I have everything else working just fine, the issue is this file size limit. It seems to me that there is a timeout happening, which is preventing the transfer to occur. Here is a screenshot of the event log.

The error in question, Event 28607, does not really have much more description in the error codes list - so I am not sure what it even means - just says the action failed.


#5

You can adjust the timeout settings in the config.txt:

FTPC_SDTO:60     for the SEND TimeOut
FTPC_SCTO:60     for the Socket Connect TimeOut
FTPC_ACTO:60     for the Accept TimeOut (=connect of Passive mode)
FTPC_RDTO:60     for the READ TimeOut

If that doesn’t help you will need to share the code (or method) you are using?


#6

Hello again - my default config file had these undefined, while yours say 60. (I assume seconds) I set mine to 300 in order to have five minutes of timeout, but the same things occurs. I don’t believe my code would be helpful, as I am not running it right now while debugging this issue. I am simply using WinSCP to push the files to the Flexy over FTP, but the Flexy continues to disconnect at 26.5MBs. Since this typically occurs around 68s, I thought it may have to do with the timeouts, but there may be larger limitations here. Would you be able to attempt transferring a ~30MB file to the SD card of a Flexy205 over FTP and compare your results to mine?


#7

I wasn’t able to test this today, but Ill make sure to try tomorrow.


#8

Thank you Kyle I really appreciate it. If you find success at 30MB, could you try something even larger, say 500MB. I suspect you will run into the same issues I was with the 30MB file, but in case that works it would be incredibly helpful to know the limits.


#9

#10

Hi Daniel,

I was able to send a 100 MB file using Filezilla directly to the card. I will try more files next week, but please try using another FTP client and see if you have any better results.

Kyle


#11

Are you sending the file over the VPN or the LAN?


#12

I just transferred a 800+ MB file on the local LAN to the Flexy’s SD card successfully, so then I tried a 60+ MB over the VPN and that was also successful.

Have you tried another FTP client?


#13

Hmm very interesting - and promising! I was using Filezilla originally, but switched over to WinSCP since they allow for more customization when it comes to scheduling transfers. I will try again via FIlezilla, and if successful, will look into how they be doing things differently. Do you know if you were using a passive FTP connection?


#14

I was just using the defaults in Filezilla so it should have been a passive connection.


#15

I am seeing the same issues using Filezilla, which is making me believe it could be an issue with my Flexy configuration. I am currently using a 128Gb SD card - is this supported? I saw that the recommended one was only 1Gb and that is not nearly enough space for this project.


#16

128 GB card is fine. The 1 GB recommendation is very old. That said, you might want to try another card anyway, or at least reformat that one as it seems to be having problems with it.

Did you say if you were doing this over the VPN or not?


#17

I will try to get my hands on another card to try out. I am doing this all over LAN currently.


#18

I got another SD card and formatted, things worked out fine. Out of curiosity I reformatted the original one I was using and it ended up working out fine as well. I then confirmed with a third SD card. It seems to me like maybe something over time is causing these issues - I will be running some tests to try and find a root cause. One odd thing I noticed from this weekends tests were that all my 157Mb files arrived on the server at only 83Mb. I manually uploaded a file from my PC to the server to confirm the server is fine. Then I initiated a FTP from the Flexy to the server using the BASIC console, and the same thing occurred. Something on the Flexy side is causing this issue. My first hunch is leaning toward the 4G connection, so I will redo the tests with a Wifi connection instead.


#19

So you are going over the VPN now?

Can you try setting the VPN settings to Force TCP? In the Comcfg.txt file change VPNPortOut from 1194 to 443. You can also change it in the eCatcher settings:
image

Has this happened with more than one SD card?


#20

So I have tried this with both a 4G connection and a Wifi connection for WAN access, but am accessing the web interface via a LAN cable - so I do not believe I am using a VPN - unless the VPN gets activated automatically every time a WAN connection is made. I am not communicating via eCatcher. Even so, I made the change in the Comcfg.txt file and still have the same result. This exact issue has happened with three separate setups I have here.


#21

Are you saying this has happened to 3 different SD cards? I did a number of transfers and was unable to replicate this. Can you explain exactly what I would need to do in order to do that?