HMS EN2SE-R PLC Program Upload Error


#1

I’m having an issue with being able to upload a PLC program when I insert the HMS gateway module onto the PLC IO Configuration tree. I import a config file that I’ve tested and used to communicate between PLC and gateway successfully to the gateway. Below is a screenshot of the HMS module added to the IO tree.

image

Once I’ve imported the config file, if an engineer were to upload a program from the PLC if the engineer did not have a copy of the program, the engineer is not able to upload and the error is shown below referring to not be able to upload the modules. I am not able to upload the PLC program as well.

image

I’ve removed the HMS module from the IO tree and once the module is removed, the engineer and I are able to upload the program.

We have a test CompactLogix PLC that is in the same family as one we are currently using for our application. We’ve added the HMS module without having the HMS module on the local PLC network and we still come across the same error so the error doesn’t look to come from the gateway hardware itself.


#2

Hi @m454,

I will need to give this a test myself. If i am understanding your explanation correctly you have a PLC setup with the Linking device added. The linking device is running along with the PLC. Then an engineer is connecting to the network and in studio 5000 doing an upload from the PLC/network. The upload fails when it tries to upload the hms-en2se-r?

Deryck


#4

Both the test PLC we have in the lab and the PLC in our application, we have added the Linking device. The Linking device is talking to a PC via serial and sending data from PC (serial) to itself then sending it back to the PLC via Ethernet/IP. The functionality of the gateway itself is working.

Both the engineer and I are trying to connect to the PLC (we’ve also tried connecting directly to the PLC since it has dual ethernet ports) and tried an upload in Studio 5000 but it fails when it tries to upload the HMS module. The upload works when I completely remove the HMS module from the IO tree.

One thing I recently came across is when I add the module without importing the config file, when we try to upload the PLC program, we are able to upload. It’s only when I go and import the config file with all the Process Consume Tags in is when we start to have the issue of uploading the PLC program.

I’ve attached the config file for reference.

gateway_config.cfg (16.0 KB)


#5

Hi @m454,

I have tried uploading a project from a PLC a few different ways and have been unable to recreate the issue. What error do you get in the module properties Module fault window?

Do you have the Add onprofile installed on both PC’s doing the upload?

Deryck


#6

You can follow these directions to un-install and re-install the AOP:

Is Studio 5000 installed locally on your PCs? If the .cfg file is being re-directed to a network drive it can cause issues with the AOP.


#7

The only error I see from Studio 5000 is the same error shown above stating no Module found.

I installed the EDS file to the PC doing the upload. Is there another file we need to install?


#8

I found the Add-On profile under the link below

https://www.anybus.com/support/file-doc-downloads/linking-devices-specific/?ordercode=HMS-EN2SE-R

I downloaded the file and the installer noted that I had already installed the profile already. I tried doing an upload again and I’m still not able to upload the PLC program


#9

I’m wondering if this is an issue where the project is corrupted on the PLC? Have you created a new device and down loaded the config to the en2se-r and to the PLC then tried uploading?

It might also be worth pointing out that the en2se-r does not need to be present for the upload into studio. Nothing from the device itself is uploaded.

This could also be a studio 5000 issue have you contacted Rockwell? What version are you using I will try to get the same version and upload with that.

Deryck