HMS-EN2SE-R unable to read from device (RS-232)


I am using the HMS-EN2SE-R to communicate with a chroma electrical tester. I have started to setup the EN2SE on my PLC and ran into an issue. I can send data out from the EN2SE, but cannot read any responses. My current setup is that the EN2SE is connected to my PLC through ethernet and the serial port is connected back to my PC. I am using the program RealTerm to catch my data and try and send a response back. I can see the data being sent from the EN2SE, but I cannot get it to read data once I try to send a response from RealTerm. I have tried playing with different settings in how I send data from RealTerm as well as how I am sending from the EN2SE, but cannot figure out how to recieve data.

The other issue that I am having is that the message that I send out always contains extra junk characters even when I have the end character settings set in the subnetwork settings.

Attached is the configuration of the EN2SE.
Generic_StandardData_7_18_22.cfg (16.0 KB)

Any Help would be greatly appreciated and if you need more information from me let me know.

First, you have a timeout set on the Consume so if it doesn’t receive data every second it times out. You can disable that by setting it to 0.

Also, keep in mind that you set the data length to exactly 84 bytes, so if the transaction isn’t 84 bytes, it won’t work. If it’s not going to be exactly the same every time, use Variable Data instead.

I’m not sure about the extra characters. Can you send the log and what you are expecting to receive?

Okay, So I have updated my settings on the HMS to not timeout with no response. And now my that is no longer an issue I can receive messages from my terminal program. But the message that I send do not get correctly mapped back to my PLC/HMS registers and I cannot figure out why. I seem to be getting portions of the message but never the entire thing. The log file below shows all of the four messages that I tried to send. The screen shots below the log file show what I am trying to send in RealTerm and what was actually being captured in the Node Monitor Window.

Log File of data transfered from RealTerm to HMS-EN2SE-R
log3.txt (1.6 KB)

Screen grabs of Real Term Messages and Node Monitor Data Captured




Config File just in case it is useful
Generic_VariableData_7_21_22.cfg (16.0 KB)

These seem weird to me because the log file shows that the module is seeing all of the data that I am sending, but the Node Monitor window shows that not all of the message is actually being captured.

I figured out the issue with the out going messages and that was because I wasn’t sending the correct deliminator character now my sent messages show as expected.

Hi @PorterHouse,

There could be a couple things happening here.

One issue is the end character 0x13 (.), which also appears in the data (1999.9). Does the manual for this device specify an end character? It looks like you’re only sending commands about every 20 seconds, so if there isn’t one specified, try setting ‘Object Delimiter’ to ‘No Character’.

The next, is that you have ‘Fill un-used Bytes’ disabled, so you don’t clear out old data that might have been longer than the new data. I would enable this and use the default Filler Value 0x00.


If those two things don’t fix the problem, try adjusting the Message Delimiter Timing. You may want to increase it a little to make sure it’s not cutting your messages short. You probably only need to go up to 200 or 300, which is equal to 2 or 3 ms. This will stop the transaction and wait for the next one if there is no character sent for 2 or 3 ms.


Let me know if this helps.