HMS IP Address

Dear Support,

I am working on a few PCB boards. I am using the B40-10 ethernet module on the these boards. Currently on an older rev, I am able to access the IP address however with the newer boards It fails as the program tries to read the ip address. I am wondering if there is an update HMS .hiff file that I need that I can not find on your website. I have tried to download the programs listed to see if this helps however they do not seem to work properly.

Thank you

Hello @iwsaf,

Can you share details between the two Rev’s? I know we recently released new firmware intended for new phy’s but I am not sure if these have started shipping yet.

Can you share more details on the issue. When you say “I am able to access the IP address” are you really accessing the Network object from the host and this is failing with the new board? Or is the program you are referring to HMS IPconfig?

For updated firmware I recommend reaching out to your Area Sales Manager or opening a support case on and provide the serial number.

Hi @iwsaf ,

I am not familiar with this code and can’t exactly debug this for you. It is not clear exactly how the IP is being requested from the CompactCom. possibly diffing into the canTransaction function being called might shed light on your issue. Where is this code running?

Could you instead possibly help me understand the part markings on the B40 chip? I am thinking something has changed between the parts on an old rev to the new rev. What is the latest verision firmware that is out?

With an old REV board and the same part, this is what I get as a result for the IP address and firmware.

Hello @iwsaf ,

You are not sharing enough details for me to be able to help you I have no context to the test you are running.

Can you share a photo of the parts markings? What is the serial number of both of the parts? With this I might at lest be able look up what they are and see if i can find any manufacturing differences.

What boards are you referring to? What are the REV’s you are seeing?

The part from the working board is:
Anybus by HMS Network
MAC: 003011354737

The part from the non working board:
Anybus by HMS Network
MAC: 003011354841

I am sorry I don’t have much more information other than this…I am just curious as to why I can only see the IP address when running my test for the working board and not the other board. There are no differences in the boards that would result to a change in the b40 module. The HMS file that I currently have as well is called this ABCC_40_EIP_7351_1_43_02.hiff and I am not sure if that is the correct HSM file for these parts or not or if any updates happened. Thank you for trying to understand.

The two device should function exactly the same. They were produced on the same day. They would have shipped have the same hardware and firmware. They are common ethernet RMII device so they support multiple firmware version/protocols, such as Ethernet/IP, profinet, Ethercat. The firmware file name you share would be for Ethernet/IP and there is a more recent version available. Since they have RMII they support Ethernet pass though directly to the host.

None of this info really answers why you are able to get the IP device. This issue may be related to how you are requesting the IP address or something else in the process.

Hello @iwsaf,

Any update on this other wise I will mark this as solved.

Using the IPConfig tool, I was able to get an IP address of … how do I know what IP address to to use for the product?

The IP would be chosen based on the network the device is set to.

When I try to configure the B40 using IPConfig, it will give me an errorr such as Error: Failed to apply the configuration. Why would I not be able to change the config?

You are most likely setting a value that is not valid. Here is a screen shot of a valid config. Please note that if the gateway or DNS is not used is used.

When I enter information it says, the configuration was rejected?

Can you share a screenshot showing the values you are setting in IP config. You may be setting an invalid setting.

I figured it out, I was connected with an ethernet cable! Thank you, I have solved the rest of my issues, appreciate the help.

Hi @iwsaf ,
Glad to hear it is resolved.

I’m not sure i follow, IPconfig is intended to be used though the network interface.