How do I configure the Bolt to allow me to connect via bluetooth?

bolt
wirelessbolt
bluetooth
configuration

#1

I have wired my Bolt up to connect to my PLC and want to be able to connect to it via Bluetooth. Is there any documentation explaining how to configure this?


#2

To allow your PC to connect to the Bolt you need to set the Bluetooth mode to NAP (Access Point) mode. This will allow other devices to see it and then connect to it. Follow the steps below for configuration.

  1. Connect to the Bolt through the LAN connection.
    • Default IP 192.168.0.99
  2. Configure the LAN settings
    • Set the bolt to be in the same subnet as the devices you will connect to on the LAN.
    • Enable the internal DHCP server if desired.
      • DHCP request are responded to though both the wireless and LAN connections.
      • Do not enable if there is a preexisting DHCP server on the network.
  3. Under Bluetooth settings enable and configure the Bluetooth.
    • If not already checked check the enable box.
    • Set the operating mode to NAP
    • Make any desired changes to configuration
      • Local Name is the name of the Bluetooth device you will see when connecting
      • Connectable allows devices to connect or not.
      • Discoverable allows other devices to see the device name.
      • Security mode
        • Disabled: Any device can connect with no security.
        • Just works: shares a encryption key but allows any device to connect.
        • Pin: allows only people with the pin to connect
  4. Save and reboot.
  5. Connect with your PC.
    • Connect a Personal Area network (PAN)
      • In widows 7 you can do this by clicking on the Bluetooth icon in the notification area and select join a personal area network.
      • Pair to the Bolt
      • Join the PAN network.
    • If there is no DHCP server enabled you will need to manually set an ip address to the adapter.
  6. You should now be able to connect to the LAN devices.

RSLinx interface to AWB2000-B
#3

The above instructions work for a laptop, but how do you connect via a mobile device? (Android, iOS)


#4

With the current firmware 1.1.6 on the Bolt/Bridge, iOS and Android are not able to connect to the bluetooth access point (NAP) created. It is recommended you use WiFi for access from a phone. Another option would be to create an access point on your iOS device and pair the Bolt.

We are working on another option to allow mobile devices to connect via Bluetooth that should be available in a future release.


#6

I tried to connect using the above procedure. The bold is found as a Network Infrastructure Device. When I try to connect I get an error message that the Bolt needs more configuration, contact manufacture. PC is running Win 10 64 Bit Enterprise V 1607.

Post Update: I was able to connect

Connecting to a ControlLogix PLC via Bluetooth. RSLinx connected to the ControlLogix systems.

image

Bolt configuration.


#7

@Alan200 Glad to hear you got it working. I’m not familiar with this message, where were you seeing it? Was this a Windows alert? The above directions were done with Windows 7, Windows 10 might have some slight differences.

Deryck


#11

It was a Windows alert.


#12

Using FW version 1.3.8, I was able to connect an android phone to the bolt via bluetooth and browse the industrial network via web browser on the android device, but ONLY if Wi-Fi and Mobile (i.e. 4G) Wireless Networks were turned off. Is this related to the known FW anomaly regarding DHCP relay running over Bluetooth? I have Layer 3 IP forwarding turned on (same Bolt settings as Alan200’s post above).


#13

Its hard to say with out knowing the complete setup. I think this could be an issue with how android favors networks. Is probably seeing that Bluetooth network as a secondary network without an internet connection.

Deryck


#14

A post was split to a new topic: Bolt via Bluetooth where the laptop is the NAP


#15

A post was split to a new topic: BOLLT HEALTH App