Internet and VPN connection fails every minute


#1

@anongrbkvpho
Customer has an eWON Flexy 205 Device that looses internet connection every minute. His current system has a Verizon Cellular connection that has a GSM strength of 24. He is using the unit as a gateway device for a connected Edge unit, that sends device status updates every 15 minutes. The address of the device is set as the gateway, 192.168.0.2. When we change the IP, the device maintains the connection perfectly.

The issue on hand is that the eWON device fails connection when it acts as the gateway of the device. We will need to find a resolution for this issue. Customer has supplied the most recent back up for the unit.


#4

Hello TJ,

I do have some documentation that may be a workaround for the issue that you are experiencing.


#5

Kevin,

This did not fix the issue. This was how it was setup before we did a factory reset. Please let me know when you have any other information.


#6

Hello TJ,

Can you provide the Edge device specifications? Also, i am still researching this issue. I just came across the NAT1:1 and through we could try it.

Can you reach out to Verizon, and ask if they are aware of any cellular modems disconnecting before a minute?

I would need to eliminate all possible sources, before i kick this up to our next tier of help.


#7

I really do not think this is a network provider issue. Can you test this on your side to see if it does it on a Verizion unit?

I disconnect the Edge device and I only have the our tablet connected to this device. Our tablet device were are using is an SMT70 from Endress+Hauser. We are trying to NAT this device to the outside, we are just trying to get internet access to the LAN ports. then we want to use VPN to access these devices in needed.

Can we please escalated this so we can please get this solved soon.

Thanks for all the help on this issue.


#8

Here is the info on the computer that we have connected
https://www.us.endress.com/en/field-instruments-overview/system-components-recorder-data-manager/device-configurator-fieldxpert-smt70


#9

Hello,

I talked to my team for further investigation.

When the Flexy has devices connected to it, the VPN becomes unstable. Through our tests, we verified if we adjust the LAN ip, the VPN becomes stable again. Our team has reviewed the back up of the unit and we find that there are gateway connection issues. Have you tried setting the connected devices to to look at a Gateway, that is not the Flexy IP?

Can you change the LAN IP of the Flexy to within the Range of the connected devices, but not the IP of the gateway. Allow the Flexy unit to establish the gateway with the Verizon servers?

If you are able to get a stable VPN connection, can you connect the vpn, and communicate with the tested devices?


#10

hello,

Checking our Knowledge base for this issue, I have found another document that may shed some light.

Assuming the 4g troubleshooting document, I would advise to reach out to the distributor to update the Modem.


#11

Kevin,

Here is the version of the modem card that we have.


#12

Hello TJ,

Due to the Firmware version listed for the modem is a earlier firmware (17.01.573) than the documented case (20.0.502), I will need to escalate it to our team in Belguim.

I will follow up with further instructions as soon as I receive them.


#13

hello,

I would advise update the firmware of the modem to see if the issue is still occurring. Please follow the instructions in the document below:


#14

Hello TJ,

I wish to inform you that our Talk2M servers have restored to normal functionality.

I apologize for the inconvenience.


#15

Kevin,

What is the status of this issue? You told me that you were going to escalate this to Europe to help get this solved.

Please update today. We are needing to ship this device out tomorrow.


#16

Hello Tj,

I reached out to our team regarding a screen share session and/or ecatcher access. I have not recieved an update from the programmer assigned to this issue. I have sent a message, but i don’t expect a response today, due to the time change.


#17

Kevin,

Thanks for reaching out to them. Please give me an update first thing in the morning on the remote session.


#18

hello tj,

Can you updated the timezone of the device to local time the device is at? It’s currently set to GMT which is in Europe, but if you trying to connect to the east coast, that has know to cause a connection error as well.

The time desync, may be affecting the PLC’s as well.


#20

Kevin,

Just updated the time and it still is rebooting the connection. It is taking around 5-10 minutes to before it starts to reboot.


#22

Hello TJ,

i haven’t recieved word for the associate in Belgium. He may not be available today.

However, I can do the remote session with you to look at the unit again.

For tests right now, from the back up I see that you are using a cellular modem with xx.vzwstatic APN. Can you try using the vzwinternet APN? We usually don’t see the static APN deployed, so we need to eliminate that as a potential root cause.


#23

Kevin,

What is the update since our last remote session on Friday? Do we have a solutions yet? Did Europe every respond?


#24

Tj,

I took a look a the files further and the recent event logs.

From what the event logs show, the device is working as it should. When the VPN closes, it shows no errors on the device side that would close the VPN straight out.

Verizon has been known to be unpredicatable with our product. from what i can see of the evidence is that the APN may be at fault. if you wish to proivde internet access to the devices behind the eWON unit. I would advise following the documentation attached:

As of now, your connection does remain stable for a longer than a minute now. The connection hshows the status to last 3-10 minutes. This leads me to believe that it may be an issue with the provider, and how their network functions.