Invalid input data size with communicator

After adding my communicator to RSlogix I keep getting the following error message.

(Code 16#0128) Connection Request Error: Invalid input size.

What is causing this error?

This error typically occurs when the amount of data allocated on the communicator does not matching the size configured for the module in the PLC. You will need to look at the IO sizes the the module is configured for and make sure it matches what you have in RSlogix.This can be done by right clicking on subnetwork > subnetwork monitor. From this page you will see the input and output sizes in bytes at the top of each section. You will need to convert this to the data size you are using in RSLogix. These sizes will change based on the data transactions configured on the module, so if you edit your configuration on the device you will also need to update the size on the PLC.

SINTS = 1 byte
INT = 2 bytes
DINTS = 4 bytes


1 Like

I am also having this same issue and have followed the application note SCM-1202-056, but I still get the error. Can you offer any other advice?

I would double check the config on the module making sure it matches exactly what you are using in studio.

Also, make sure you are using the correct EDS file. Alternatively you can add the device as a generic device, described in this app note.


I also have this issue, I can’t find in the application note where I should put the correct data size. Is it in the device configuration or in the Controller tags ?

Since the controller tags for this device are automaticaly created I can’t edit them.

Hello @Kevin_FivesServices,

After you configure the transactions on the module you will be setting the IO size in the module definition window. There is an example of this on page 12 of this app note.