Issue in ewon Flexy

I have a Flexy that is giving the following error:

20314 Reboot reason: Watchdog in process (main) wd
-31111 wanmgt-Dial on demand failed because If Forwading disabled wanmgt

Is there a list of generic errors to know the cause of what happens with this equipment?

Can you supply with a backup with support files? This can be done using eBuddy.

What is the internet connection for this device?

Tomorrow i will send you a backup. This flexy is in remote location.

This flexy doesn’t have internet connection. Is there an option to disable it for dissapear the message “31111 wanmgt-Dial on demand failed because If Forwading disabled wanmgt”??

Were you able to get the backup?

1 Like

where do i send you the backup file??? i’m in the remote location and get the backup from ewon flexy


You can post the backup with support files here. We will move it to an admin on section for us to download and review.

Backup hidden

Hello Tommy,

I am reviewing the back up now

Hi Tom,

I see in the Backup that you have WAN communication disabled. This would be why you are getting those error messages.

I see that you set a static IP. when you did this was it though the internet wizard or did you change it in the COM config file? I would suggest possible running the internet wizard again to resolve this issue.

Hi Zach,

We aren’t currently using the internet connection, the flexy is only used locally through a computer that is connected to the site. Is there a way to temporarily silence that glitch so that it doesn’t come out anymore ???

So you have WANCnx set to 0 which is causing issues since you have other settings that seem to be trying to use the WAN connection which currently does not exist. Looking at the log it is happening after trying to set the time. I see you are using to set the time which it cannot currently reach. Switching the system time to manual instead of update via an ntp server might fix the problem.

Hello Tommy,

Are you still experiencing issues with your Flexy.?

Hi Kevin,

I haven’t tried it because I’ve been busy. As soon as I test the recommendation I will be notifying.


Thank you, I will keep the topic open for your response.

Hi Kevin, the problem has not been solved with the switch of the clock to manual. Is there another way to not get that error in the flexy?


can you try updating the firmware to 14.3? This can be done using eBuddy while connected to the unit. Since you are running firmware that is a couple years old. It could be the the later versions resolved the issue that you are experiencing.

Events (1).htm (292.8 KB)

Hi Kevin,
I have updated the firmware to 14.3 in other ewon. I’m working with the ewon that it was in production and i have this issues in the event log. Can you check these bugs and say me what is the problem??? This ewon flexu 201 have the firmware 13.2

The Udevemon is referring to the SD card that is inserted in the unit.

Can you have it removed, and verify that the reboots still occur or not?

The only way that i have solved this bug is disabling the program in Basic IDE. I have a little code for save the historical data every hour in SD. But I need to keep saving this data. This is solved performing a format in ewon and download everything from 0. But in 4 months approximately fail again.

You can try backing up the SD card, and reformatting it to see if that resolves the issue. Or you can format a new SD card to backup the data.