IXXAT CAN bridge


#1

@anonxvdebyki
Hi Danny,

I am sending a ticket to our IXXAT team, but wanted to check if you have tried changing the setting ‘CANBusOffRecovery’, which can be ‘no’ or a value of ‘1 - 60’ (see page 14 in manual - https://www.ixxat.com/docs/librariesprovider8/default-document-library/products/repeater/canbridge-manual-english.pdf?sfvrsn=6).

Kyle

  • on first power up, everything on the CAN network comes on at the same time as the bridge, but CAN 2 is not online, has to cycle power on CAN 2, raised the timeout, had more problems, decreased the timeout setting and happens less often, has CAN going down 30 railroad cars w/bridge in middle, 200-300m on each side, baud 125, each node on can 1 and can 2 has its own power supply, ground is common among them. setting to compensate possible race condition?

#3

·

· ** (Have to cycle power on the CanBridge NT200) or Cycle power on entire system either way corrects communication on Can2)**

·

· on first power up, everything on the CAN network comes on at the same time as the bridge, but CAN 2 is not online, has to cycle power on CAN 2 , raised the timeout, had more problems, decreased the timeout setting and happens less often, has CAN going down 30 railroad cars w/bridge in middle, 200-300m on each side, baud 125, each node on can 1 and can 2 has its own power supply, ground is common among them. setting to compensate possible race condition?


#4

Danny,

I’m sorry I wasn’t able to get back to you Friday. Can you check some things for me:

  1. Could you please let me know the LED status on the CANbridge NT 200 when the problem occurs?

  2. Could you please let me know if you can check if there are Error-Frames on the CAN2 or CAN1?

  3. Could you please let me know if you can check the CAN signal quality on the CAN2 using an oscilloscope?
    (maybe there are electrical disturbances that cause Error-Frames and a CAN-Bus-Off status)

     CAN1 200-300m               CAN2 200-300m   
     Node1[R]-------[R]CANbridgeNT200[R]-------[R]Node30
    
  4. Please set the “Start-up Delay = 0” and configure the “CAN-Bus-Off recovery” for CAN1 and CAN2 as on the below attached screenshot and let me know if the problem does not occur anymore.

Thanks,
Kyle