KUKA Robot and Ethercat - Modbus TCP X-Gateway Problem


Ethercat Slave:

We are trying to establish a connection to Ethercat X-Gateway Slave with a KUKA robot thrue robot software (WorkVisual 5.0)

We imported ESI file with PDO’s included that we got generated from HMS Support. We imported the file in to the Robot software and mapped some I/O’s. The ESI file have Same Revision numbor on the ESI file as the X-Gateway. But it seems that there is still a connection problem somehow.

It is a similar problem as a recent topic posted here in the forum:

I have heard that maybe we need a extra software from Anybus that allows us to communicate with the X-Gateway with the Robot?

Any help and advise would be huge!

Kind Regards,

Can you describe the problem in detail?

I am not exactly sure what you are referring to here. You may have seen an example where another software was used with a specific device. The software you will need will be the Anybus Configuration Manager and the WorkVisual, which I don’t think has ‘‘get PDO from device’’ function so you can use the ESI generator or use this for 64 bytes in and out: ABX_V_3_29.xml (2.9 KB) if that works for you.

Please provide some more info about the error and we can try to help more.




Yes exacly there is no get PDO from device in workvisual but thats not the original issue. I have a ESi file which contains 64 bytes in and out. I have Imported the ESI file in to the WorkVisual software. Mapped I/O’s to the Gateway all these steps seems right. After deploying all the settings in to the Robot Controller i get two error messages which are:

KSS13080: Ethercat Device Anybus X-Gateway - Slave cannot be started.
KSS00099: Error on reading/writing sys-XX44
these are the errors i get.

OK so there is no extra software needed from Anybus to get the communication, i got that confirmed from the HMS Support…

Kind regards,

I am not familiar with WorkVisual, but I am assuming that it is an EtherCAT configuration tool, like EC Engineer or TwinCAT. It just doesn’t have the option to scan the PDO. Do you have any more info about those errors?

I know the Acontis ECE software will work and even TwinCAT might if you want to scan the device with those.

How is this going?

I did come across this forum where there is a lot of information involving the Kuka robot and WorkVisual. This guy had the exact same error as you and was able to resolve:



Yes the problem is solved… The issue was that the ESI file i requested from HMS was not 64 Bytes IN/OUT but was 16 Bytes instead. And I never double checked the file actually… I changed the PDO size in the Anybus Gateway from 64 Bytes in both direction to 16 Bytes and it worked perfectly afterwards…

Thank you for your support.

Kind Regards,