LAN Gateway

We are unable to access the Flexy 205 over the LAN network from the server (you can access the Ewon when you plug into it with laptop), but everything else that’s connected on the LAN ports on the Flexy we can see and access. (different devices).

Did a test by connecting a laptop to the flexy lan, but did not enter a gateway. The server could not see the laptop, then we added the server IP as the gateway and we could see the laptop. this proved that we might need a gateway in the Ewon for the server to be able to see it.

when you are connected over the VPN, you can ping the devices that’s connected on the LAN network.

Hello @Waldo ,

I am having a hard time determining your question here? It seems like you might have an issue with the routing to the ewon but i am not sure i understand the full network layout or what device is trying to reach what device. Are you remoting in with eCatcher and trying to reach the Server?


Hi Deryck,

let us take any remote access out of the equation.

so there is a local server on site on the same lan network as the Flexy. The client is trying to access the flexy from this server. (or ping it) unfortunately any device that does not have a specific gateway address cannot be seen by the server on the lan network.

The LAN ports on the flexy work as a unmanaged switch so any device connected should be able to reach each other. Based on you drawing i wonder if the are two networks involved.

what are the IP addresses and masks for the devices.

It is only one network. you can see the units that you plug in on the Flexy, but the Flexy itself you cannot see. an example: if you plug your laptop in the flexy without adding the server IP as the gateway, then you cannot see the laptop from the server. But if you add the server IP as the gateway on the laptop then you can see the laptop from the server.

IP range : 10.184.196.X

Server IP :
Mask :

Flexy IP :
Mask :

the only common denominator is the gateway setting not changeable on the flexy itself. The problem is not the devices plugged in on the Flexy, it is the flexy self in the sense that the Flexy cannot be accessed unless it is pointed to the server from where all the engineering is done.

I am having a tough time understanding what you are trying to do here.
I am wondering if the swtich and firewall between the ewon and the server are doing some natting or other routing. Can you elaborate further on the purpose of those?

Two other questions

  1. What is the IP of one of the LAN devices connected to the Flexy?
  2. What device is creating the connection? is the LAN device

Hi, Having the same issue. The ewon is sitting in an OEM machine and needs to communicate to an external LAN on a different subnet for data collection. I have got the other devices working using NAT on an external router but the ewon will not communicate for what I can guess cause I cannot set the gateway on the lan ports.
The goal is to have the ewon flexy using the modem card while segregating the machine off from the plant network.
Flexy LAN IP
External access via IP
This works for the PLC which I can set the gateway on.
Any assistance would be awesome.

Hi all,

After some brute force testing I have discovered that with no addon cards the NAT works as expected via external router. In this config the ewon is just an end device and NAT is via another router.
As soon as you install a WAN card the ewon stops responding. I also noticed the eth1 LAN config page drops the Gateway and DNS options, and the eth WAN page has the same config that was previously in the LAN config. I assume this is sharing the config and disabling something on LAN.

I though I had success as I no longer needed the WAN card to do NAT and with the 3G card installed without the WAN card the ewon started responding again.
Next step was to initilise the 3g modem and get it online.
And to my supprise as soon as the WAN connection was made the ewon stopped responding on LAN via the NAT router.
Disabling the Internet connection returned the eWON to responsive state via the NAT router.

So, at this time, the eWON cannot be used in with a external router that used NAT to access the ewon if any extension cards are installed or in use. This is not ideal as it removes the remote access feature. Ideally we could use the ethernet WAN card NAT function at the same time as the modem but that has been discussed before.

This doesn’t seem like logical behavior.
Are there any settings I’m missing?
Any response would be helpful.


Hi @barryt,

No, I don’t think the problem is just settings. It’s also understanding the concept that the Ewon is a VPN router, so the default gateway for the LAN network always has to be the Ewon in order for traffic to be forwarded to the WAN and/or VPN networks.

If you want to connect the Ewon to other networks on the LAN network, you will need another router. You may also have to add routes to this router in the Ewon’s static routing table. In the Flexy, you can do this in ‘Setup > System > Communication > Networking > Routing’. In the Cosy, you will have to add routes in the comcfg.txt file (Setup > System > Storage > Edit COM cfg). The settings are RouteDestIp#, RouteNetMask#, and RouteHops#.

If you need to reach this other LAN network from the remote PC (running eCatcher), you have to create a static route in the PCs routing table to point to that network.

I hope that helps somewhat explain the problem and what needs to be done. I’m not sure I fully understand the details of your situation, but it’s essentially a routing problem.