Latest Firmware for AB7670-F

How do I get the latest firmware for the AB7670-F with Serial Number A055FB07

That device is new and doesn’t appear to require a firmware update. I don’t recommend trying to flash firmware unless it’s necessary.

I’ll post the firmware below, but I don’t recommend updating it, unless there is a good reason. You can brick the device if you make a mistake.

Release information.docx (48.0 KB)
FWP_ABX_V_3_29_01_D.fwp (73.6 KB)

To update the Web interface, unzip, and transfer these files to gateway via FTP to overwrite the existing files. FTP credentials are ‘ABX’ | ‘FTPAccess’ (143.4 KB)

Hi Kyle,
This is a new device, we have been talking with support from the company we purchased this from and they recommended a firmware flash due to a problem we are having.

This new out of the box device, we are having trouble connecting via USB connection to configure it. It will sometimes connect, then timeout, and not allow us to perform any configuration changes. We have tried different cables, and two different computers and the problem persists.

The specific errors we are getting are:

  • We see the module when we choose connection (serial number shows up) and we can connect (sometimes). However after connecting if we go to “Set Operation Mode” the screen will sit there and eventually come up with Operation Mode: Not Available. (See attached screenshot).
  • When trying to upload after connecting, we get a “Timeout when communicating with the module” (see screenshot).

    Screenshot 2022-08-15 092725

Our support channel is not a lot of help on this. Have you ever seen this issue before? Do you think a firmware could fix it?

Yes, we have seen this issue come up before with some versions Windows 10. I believe there was a Windows update that caused this because we have only started seeing it recently and we do not have a firmware fix yet. However, there is a very simple workaround. If you power cycle the gateway when you receive this error, you should be able to then click OK and retry and it will download. We have also found that sometimes it works to simply unplug the USB cable and plug it back in.

I tried both power cycling and re-plugging the USB and was unable to change the operation mode or send the config. Just for fun I made sure I had all the latest Windows updates installed in case Microsoft happened to fix whatever is causing this. No luck.

Do you happen to know which update (KB#) that caused this? I could try rolling that update back.

No, I’m sorry, but I don’t. If you’re having the issue that I’m talking about though, rebooting the gateway should fix it.

Make sure that you don’t hit OK on the error. Power cycle the gateway, then click OK. This almost always works for customers having the issue. If it doesn’t then I believe something else may be the issue.

I’ve tried power cycling and disconnecting the USB and I still cannot get it to do anything.
Our support through our vendor recommended flashing the firmware, or do we have a bad unit?

Have you tried flashing the firmware using the fw file and instructions above?

I have, and I’m getting the message unable to download firmware.
Given that the USB attempt failed I did not try updating the web interface.

Can you create a support case at We may need to have a remote session (via Teams or Teamviewer) to try to diagnose this and if we cannot, we’ll have to RMA the device. Are you available for a meeting this week?

I have opened case 61163 for this.

I am available anytime for a teams meeting. My e-mail is attached to the ticket you can send me a link there.