Latest firmware for ASG4102


#1

Is WEB-PLC V9.0.6 the latest firmware available for the ASG4102 marked V1.0, 2016-47? If not, where can I download the latest version?


#2

Hi Adam,

There is a newer version, I just need to get confirmation it is OK for release.

Investigating your issue with the Modbus value, it appears it may be a bug with the firmware:

 Ticket 2209: Modbus Slave: Wrong data type when editing first value after loading website - 
 When editing the first Modbus slave value after loading the settings website, the data typeshown in the value dialog may be wrong.

 Workaround: Cancel the value dialog and open it another time

Not a great workaround, I know. I will verify the latest stable version and can update you tomorrow.

Thanks,

Kyle


#4

Thanks Kyle. I actually submitted another post asking what the latest firmware for this device is, as I’ve noticed a number of other issues. The original post I made about decimal to integer rounding resulting in 0 has been worked around by re-creating the project from scratch (I did not have that problem the second time around), but I do have some other issues including this one.

The most troublesome of the other issues is modbus writes to the device where the SG is a Modbus slave don’t always work. Sometimes I get no response (a packet capture shows the connection closing) and other times the value is written and I get a valid response to the write command. This seems random; I might try to write a value and it goes through on the first try; or I might have to retry 12 times before it works. I wanted to get the latest firmware on the device before escalating this and the other issues in case they have been fixed.


#5

Hi Adam,

Here is the response that I received from the developers. I have also attached the latest firmware version for your device.
"
this is older hardware with slow CPU - the latest firmware-version is **Anybus_SG_v9_0_8-sc1x3.cup (3.3 MB)
** as I attached
for downloading. The configuration might be lost during the update. With newer firmware the config is staying alive.

Also the customer could test if it helps to change the multiplier constant from 10 to 10.0 - this could be a reason in this very early versions, to make sure calculating with float formats.

If this can not fix the problems so it might be time to replace it with a new Ixxat SG-Gateway by contacting Martin Matt. The SG is much faster now, with much less limitations and bugs - even we are still improving it before ramping it up for open market.

Here You can find all downloads for the SG-Gateway:
https://www.ixxat.com/support/file-and-documents-download/energy-sg-gateways
The latest firmware is 18.2.14
"

Please let me know if you have any more questions or there’s anything else I can help with.

Thank you,
Kyle


#6

Thanks Kyle. I’ve put in a request for my company to buy me one of the new devices and it was approved, hopefully I receive it soon. I have installed the firmware you shared with me on the old device and it seems to have resolved the intermittent Modbus write problem so thank you for that. I’ll refrain from posting about further issues with the old SG device and consider it end of life.


#7

I’m glad that helped and you’re getting the new device. Feel free to continue to post any questions or issues about this device in the meantime, if we can help we will!


#9

Hi Adam,

I wanted to let you know that I did get some additional info from an engineer that looked at your configuration files. He said:

" The output of the MUX is inverted and that doesn’t work on float and integers, so if the customer double clicks on the output to get rid of the circle then it will work."

Kyle


#10

Thanks Kyle.

I’ve completely re-done the project with 32 bit integers and that solved this problem. Still outstanding are:

  • All modbus inputs revert to 0 when the device reboots, as opposed to the last value set

  • The device locks up and must be hard power cycled as frequently as every few hours but usually after a day or two of operation

At this point I am just waiting for the new IXXAT version of this device to come in hoping that it doesn’t have these issues; if it does then we need to fix them quickly or I will need to use a different product for this project.

Adam


#11

#12