Logs show 10 bytes but only consuming 7-8


#1

@anonufgvmzte
Hi Ed,

Can you send me a copy of the log and configuration.

Deryck


#3

log.txt (1.3 KB)
test_485_config.cfg (16.0 KB)
Communications Protocol (003).pdf (7.7 KB)


#5

comlogdata.txt (855 Bytes)
Here is a wire shark com package grab from the device. From this data, Dec # 55 should be the first character coming into the Anybus device.


#6

Comparing the log files I think you are getting garbage data to the anybus. Looking at the communicators log file we see a significant number of 1’s in the data:
1 0 0x50 80 P
2 2 0xD9 217 Ù
3 1 0xFF 255 ÿ
4 2 0xFD 253 ý
5 2 0xFF 255 ÿ
6 1 0xE3 227 ã
7 1 0x37 55 7

My guess is that one of the serial setting does not match what your PC is using with that wireshark capture. Can you check the settings the PC is using and compare it to the Communicators?

Deryck


#7

comlog1.txt (19.6 KB)
any_bus_desk_422.cfg (16.0 KB)
anybus_stop_bit2_log.txt (3.3 KB)
Deryck,

Here’s a different config file (at my desk), the config file from the wire shark program (2 stop bits), no parity, and a log file that I ran after downloading that configuration to the anybus communicator.

I’m really confused because I would not think it would be this difficult to bring data into a communicator.


#8

The communicator is not typically this difficult to get working.
Were you not receiving the right data when testing this at your desk? Does the new location use different serial settings?
I am not able to determin what settings are wrong in your setup. But the 0x55AA seems to be there to check the data stream. Is would be giving you 0b101010110101010 two bytes of alternating 0’s and 1’s from all the logs you sent me I do not see this anywhere in the communicators logs indicating the serial settings are not correct.

Looking at the most recent .cfg The first thing I would ask you to double check is the physical standard, it is really using rs422? Next I would question the parity. The stop bits are only used at end of the frame I would not expect them to effect all of the data as you are seeing.

Deryck


#9

Deryck,

I was testing stuff out on my desk, and the only way I could get the communicator to get data was to switch it to RS422. It should be RS485, but I would not get any data using that.

When connecting to my PC via the same equipment (disconnecting the serial connection from the communicator) I would get the data stream I sent you via wire shark.

Again, I have no idea why this is not working, but I am getting to the point where I need to look at another option to start collecting this data. I do not know if there’s anything else I need to try in order to get this working.

Please advise,
Thanks


#10

What are you using for a serial port on the PC? Typically a PC is going to have a RS232 port, were you using an RS422 adapter or something on you PC?

Would you be able to set something up so we could have a teamviewer session with the communicator connected to the actual device?

Deryck


#11

Deryck,

I am using at Keyspan Serial to USB device to create a serial device on my computer. The com port is set to COM2 on my computer for this connection. On my computer, I do not delegate what type of serial communication I am received, it just comes in as serial.

At the physical device that is producing the signal (which transmits at RS485), I have a serial plugged that is wired for RS485 (Signal Ground to pin 5, RS485+ to pin 8, and RS485- to pin 9). That serial connection is connected parallel to a RS485 signal that is then converted to RS232.

The second connection is transmitted to a splitter, one side of the splitter is connected to the same Keyspan serial to USB device. The computer has software that reads the serial signal (HEX data) and converts it to DEC, and then records the data it received. The other side of the splitter is connected to a B+B Smartworx VLINK Model VESP211/232 device. This device changes the signal from RS232 to TCP/IP and is transmitted on the intranet to another VLINk device, that takes the TCP/IP signal, and converts it back to RS232.

I have one of those devices at my desk. When I try to connect the communicator to that device, it will not collect data via RS232. In order to collect data at my desk, it has to be RS422 (which does not make sense).

The real issue I see that if I’m either at my desk, or at the physical equipment, I am not seeing all the data, even though if I connect my computer to the device, I can do a wire shark and see the data come through correctly.

My schedule is pretty open tomorrow morning. I do not know what your schedule is, but if you want to connect up via team viewer, I can work with you on that. I normally get into work at 0630 CST. The area in question usually starts breaks between 0845 to 0900, and then goes on lunch at 1030 to 1110.

Let me know what works for you.
Ed


#12

Hi Ed,

Sorry for just getting back to you. Would you be able to do something at 1:30 EST?

Deryck


#13

Deryck,

I can make that work. You can call me at 920-245-9339.
Thanks,
Ed


#14

Hi Ed,

I apologize I did not see your response and was caught up on another issue. I left you a voice mail with a direct number please give me a call and I should be able to jump right on a teamviewer.

Regards,
Deryck


#15

Deryck,

The process is done for today, so we will have to look at this tomorrow.

Thanks,

Ed