Lost BasicIDE code


#1

I have had issues with the code sections in the Basic IDE. Sometimes it won’t display, but today I was moving from the tag values window to the IDE window a few times, then all the basic programming just went away and was not recoverable. What’s up with that?
Thankfully I had done a eBuddy backup a few hours before, so did not loose too much, but this has me worried. Is it because I am using Google Chrome?
Post script: I am connected to the flexy VIA a ethernet cable.


#2

Hi Tom,

Sorry to hear about this - can you make a backup with the Support files included so I can take a look at the logs?

Kyle


#4

Can you call me please? i am having another issue on site right now

Tom D.
541-817-6893


#5

Talked to Tom about setting Timezone offset and Historical logging not showign up


#6

See the attached file. I am pretty sure I saved this including the support files. Let me know.

T Duclos

MOVED TO STAFF NOTE (26.5 KB)


#8

Hi Tom,

I went through this and can see that the BASIC code is gone and the tags are still all there, but there weren’t any log files to see what happened. When you go to Backup/Restore in eBuddy, next time make sure “Include Support Files” is also checked. It does seem like the browser screwed up the file the way is disappeared like that.

Thanks,
Kyle


#9

Note:
I have been trying to make the browser window NOT show the basic IDE code when using a iPad. I have not been able even once to get the basic code to be invisible withh an iPad.
However, when using a Windows based computer, it is invisible quit q lot of the times I look there. I will see if I can get acces to a Mac desktop PC and try that.


#10

OK and I thought I had.

By the way, I loaded Firefox and tried it for a browser, and still have
issues when sometimes I go to the Basic IDE, the screen is just a white
window where the code would be. If I go away and come back, to any other
screen, it usually s happens on various laptop and desktop PC’s but have
not yet seen it happen from any other than windows based operation
system.

Keep working on this please.


#11

Tom, when this is happening, are you connecting to the device locally? over M2Web?


#12

Let’s do a TeamViewer session at some point today so you can show me this. Let me know what works for you.


#13

That will not be possible, I am traveling today and tomorrow


#14

I connect using eCatcher.


#15

We can get together on another day. Let me know when you will have a few minutes. I just need to see your screen when you connect to the device so you can show me what you are talking about.


#16

Kyle:

I am at a hotel now for the night, if you call me we can connect
541-817-6893


#17

#18

Update on invisible Basic code:

I have tested this a bunch in the last 24 hours. I can now say that the same problem happens with my iPad as it does with any Windows based computer:

Sometimes, when going into the Basic IDE, all of the logic will just not show.

Usually, when I go to another screen, such as “values” and then go back to the IDE window, then the Basic code will be visible; not always, but most of the time. Sometimes I have to get all the way out by closing the browser, then reopening it.

Also, it does not matter which browser I choose to use, I have tried Chrome, IE, and FIrefox.

Could this be the result of using the free version of eCatcher?

This problem happens whether or not I am connected directly with a Ethernet cable, or going over the airwaves.

Please help!


#19

Hi Tom,

Sorry I missed you. I am typically here from 8:00 AM to 5:00 PM EST on weekdays.

Are you using the default admin account “adm” on the Flexy?

Just to confirm, you said this happens when you connect with eCatcher and when you connect locally?

How many different devices have you tested, you mentioned a Windows PC, Windows laptop, and iPad, so 3 different ones? Has the Flexy been on the same network each time, or have you moved it to different sites?

Which firmware are you using on the Flexy?

Let me know if you have a chance today to show me this over TeamViewer.

Thanks,

Kyle


#20

In flight at his moment. Will be in Kansas City shortly. Then we could
talk by phone if I had your number.
I have three flexy 205 on line currently. In all cases I have had the
same experience with each both at sites or connected locally via
Ethernet.
You are welcome to go online with my Tom’s house unit, you can’t hurt
that’s one as it is not doing critical work.
If you need my account info, I will provide it.
I wonder about using the free “eCatcher”, is that the problem?

Will be in Kansas City soon. Can I have a help phone number to call
you?

TD


#21

All of my flexy unit have been upgraded to the latest version (13)


#22

Sorry Tom,
I"ve been on calls all morning, but I’ll be available shortly after 1 pm EST. you can call 312-893-5636 and if someone else answers, ask for me.
Kyle