M2Web and Proxy / Port-forwarding together

Hi, I asked the same questions years ago on the (old forum website) but, as it doesn’t have a solution yet and seems unavailable, I would like to post it here too to be able to track it.

The issue is simple: you cannot connect to your device with M2Web website (e.g. VNC, HTTP, etc.) if you enable the port-forwarding (also called Proxy in the configuration) in the eWon COSY / Flexy using the ProxyEnabled = 1 setting.
If you try to do so, you’ll get a generic unable to build proxy error, independently from the device you’re connecting to.

When will this issue be fixed?


First off the link you sent is not the old site. that is the Ewon site run by the Ewon team directly in Belgium and is still active.

Second if you wish to track a feature request the best option is using our ticket system to make a support ticket. That is where you will be able to get in contact with your local support team and it will be more visible to the development team since it can be escalated.


This post has been marked as solved, but there is no solution posted.

We have a similar issue. M2Web VNC doesn’t work if you enable Proxy->Port-Forwarding and enter in rules. We need to allow end users access a pc via vnc as well as do port forwarding to another pc on the same LAN of the eWon device. As soon as you disable port forwarding, the M2Web works again.
Any ideas?

Hi drojas,

Please create a support ticket support ticket at our technical team will be able to assist you.