Modbus IO Server Modbus TCP Port configuration to when EWON is Modbus Client

I want to read data from PLC thru MODBUS TCP/IP. PLC is configured with TCP port 503 for MODBUS. When I update EWON IO Server Global settings to configure TCP Port as 503 and restarted EWON. Still I have same issue.

EWon Firmware is 14.3S0. The EWON IO Server Global settings page in this firmware revision is not same as explained in the IO server document

Hi @MD_Raja,

What is the LAN IP address of the Ewon device and the Modbus TCP device? Is it responding to pings? Do you have disable tags in error set on the device?

-Tim

Hi @Tim_hms,

Ewon LAN IP is 192.168.0.101
PLC IP is 192.168.0.1, PLC is pinging and when I try, I am able to pole data using S73&400 IO server. But I have to use MODBUS here.

The “Disable Tags in Error” is not selected.

I have tried with Modbus simulator, when I set Modbus simulator port to 502 and Modbus TCP Port in EWON IO servers global setting is 503, still I am able to pole data. Strange !. But when I make Modbus simulator port to 503, Ewon stops polling data.

Other question, In my Ewon IO server global setting page, I have only MODBUS TCP PORT entry and not for other TCP Ports (EthernetIP, ISOTCP, FINS) as shown in your shared image. Is it related to firmware ?

Would you be ok with creating a temporary user for us to use on your eCatcher account to try and take a look at this? Or could you send me a backup.tar file of the device with support files included?