MP40 module does not initialize

Hello All,

We have been encountering an issue with a five of our M40 (PROFINET-IRT) module cards.

During the initialization process, we have observed that the card is stuck in the setup state (where ABCC_AnbState() always returns ABP_ANB_STATE_SETUP). Also, there is no way to communicate with the card via the M.2 interface (where ABCC_isReadyForCommunication() always returns ABCC_NOT_READY_FOR_COMMUNICATION).

The LEDs are as follows:

P: Solid Green
U: Flashing Green
MS: Off
NS: Off

Out of the five cards, one briefly did not exhibit this behavior. However, after a Windows stop screen occurred, the card reverted back to this behavior.

What would cause this behavior? Is there a graceful way to recover from this behavior?


Hello @josephp ,

Just want to check and to mark this as solved but i believe I worked with you on last week on this issue. For your particular issue we are working with our RMA to for a closer look at the devices for repair or replacement.

Let me know if I have mixed up the cases.

Yes, this thread is the issue from the HMS support ticket.