Nat


#1

I have a customer that is trying to setup NAT on a cosy 131 we have gone through the NAT setup and also set the gateway address on the end devices to point at the cosy. still nothing seems to work. Would like to have a call to help troubleshoot. Here is block diagram of what we are trying to accomplish.


#2

Hi @Ricer,

Can you try using the guide I made below as a reference and see if it works after that?

NAT 1to1 without vpn.docx (685.6 KB)

Thanks,
-Tim


#4

That documentation is all for mapping a device from LAN to WAN.

In my case I need to see a WAN Server from the LAN.


#5

Hello, this should still work as long as you are still connected to the WAN network.

The big changes you need to make are these:

• Search for FWRDtoWAN and set that to 1
• Search for WANITFPROT and set that to 2
• Search for NATITF and set this to 3


#6

Tim,

On the WAN Server you would need to have the IP address of the COSY, correct? On the LAN device you need the IP address of the COSY as well? That would give you your 2 way traffic. Is the COSY a Layer 2 or Layer 3 device?


#7

You’ll just need to be connected to the same WAN that the Cosy is connected to and make sure that plugnroute is enabled. what this would be doing is taking devices on the LAN and mapping them onto the WAN.

So for example, we’ll say your Flexy and PLC have the following settings

LAN 192.168.0.1
WAN 10.0.0.1
Mask 255.255.255.0

PLC 192.168.0.2

You can go onto the flexy and map the PLC to 10.0.0.2 and be able to reach it from the WAN side by doing what’s seen below:

Depending on what you’re trying to do the cosy could be viewed as layer 2 and 3


#9

Tim,
Looking at the NAT document that you attached in this feed. I cannot find the security settings that was mentioned under networking. I am on the lastest firmware 13.3 and using eBuddy to get to the router settings.

Stacie


#10

Is this the security section that you were looking for?