No module available message when trying to connect 7317-b module

I have been trying to connect to 7317 type modules that are already in use to make small change in the output area size but I keep getting the no module available message when I try to connect.
anybus communication managar no module found

I ran the transport provider so i have the necessary drivers and the module shows in device manager and I have checked that the com port is correct in the device configuration software.
anybus communicator can com9

Any ideas would be welcomed.

You are using the USB cable to connect and selecting the correct COM port (9) under “Online > Select Connection” in the Anybus Configuration Manager software?

What are the status’ of the LED lights on the Communicator?

Hi Kyle
Yes I have selected the port 9 from the settings and as for the lights 1,2,5 & 6 are green, 3 is blinking with green led and 4 is off.

Have you tried using the Ethernet port to connect?

Do you have another USB cable you can try connecting with?

Is there another PC you can try? There may be something on the PC blocking the connection.

Can you provide the serial number of the Communicator?

I can try the ethernet port and new USB cable today. I will let you know if it works and I will also add the serial number here later.

I tried different USB cable and also to connect to the module through the ethernet port that is connected to the profinet and neither worked. Do I need to have some specific baud rate at the connected port? the default is 9600 and I did try 4800 and 38400 also. I still need to try it with different computer.
Should the connection work with a default empty profile? I should be able to just open the ACM software select correct port then press connect and then upload to get the setting that are stored in the communicator?

The serial number for the module is A0404B0F

No, the PC usually automatically matches it to the device. By default I believe it’s 57,6 / 8 / 1 / none though.

Not sure what you mean by “default emptty profile”.

Yes, it’s normally quite easy. I think there is an issue either with the PC or gateway. Please let me know when you get a chance to test on another PC. If that doesn’t work, we’ll have to try to reset the gateway.

You are using the wrong software. You have a CAN Communicator and are using the Serial Communicator software. Please download the correct software for your device here.

Sorry for long delay with reply. I did indeed have the wrong software and downloading the new one fixed everything and I was able to connect without issues.
Thanks again

Great - glad you got it working! Thanks for the update.