hi all

I have a rather complicated situation where i am trying connect to an OPC UA server (Flexy102) connected to a private network provided by a private APN sim, without VPN. The IP is fixed and there is a NAT.

When connected through LAN, OPC UA client can connect.But when I try the same on the WAN, the OPC UA client cannot establish a connection to the default port 4840, which is allowed through the firewall.

Currently, I can ping from the server to the Flexy102.

Can anyone provide any advice? Thanks in advance.

Hi @Jeen,

First can you confirm a couple things:

  1. This is a Flexy 102 and not a Flexy 201?

  2. The Flexy is acting as the OPC UA Server? (I assumed it was after reading the first sentence but then you said “I can ping from the server to the Flexy” so now I’m not sure)

  3. When you say “the firewall”, which firewall are you referring to?

  4. Do you have the Flexy exposed to the open internet (WANItfProt = 2) or are you doing port forwarding? (I am assuming you are using a cellular card in the Flexy to connect to the internet because you didn’t mention another router.)



Hi Kyle,

  1. Yes it’s a flexy102

  2. Yes the flexy102 is the opc ua server, the ping test was to see if the remote server could detect the flexy

  3. The server firewall

  4. No, the sim card only allows me to gain access into the private network but has no internet access. When we did port forwarding, the ping test from remote server to flexy timed out, and when we removed port forwarding the ping worked.

Thanks for the reply @kyle_HMS

Please send a backup of the Flexy (.tar file created by eBuddy, including Support Files).

When you say:

is this over the WAN?

Here you go Kyle,
and yes, the ping is over the WAN.
We tried a script to detect the IP:Port but it returned a “No connection could be made because the target machine actively refused it”