OSISoft Connector fails to fetch WebIds or reconnect


We have couple of issues with Flexy 205 (14.2s0) and OSISoft Connector.
Flexy is using a 4G SIM to communicate with PI WebAPI over VPN tunnel.
OMF disabled.
WebAPI configured to use full WebIDs

Problem 1:
After a reboot, 4G takes some time to get back online.
If OSISoft Connector times out before connection to WebAPI is created, it just seems to crash and doesn’t even try reconnecting again.
Realtime log shows first “Could not connect to OSIsoft Server, link is down” error, followed by stack trace.
Is there a way to restart OSISoft Connector JVM service without booting up the whole unit?

Problem 2:

When connector does manage to connect to WebAPI all requests end up with error about failing to fetch the WebID, even though WebAPI server log shows the successful response


Response JSON from server Event Log
“Links”: {},
“Items”: [
“WebId”: “[WEBID]”,
“Id”: 15007,
“Name”: “TAG_XYZ”,
“Path”: “\\[SERVER]\TAG_XYZ”,
“Descriptor”: “”,
“PointClass”: “classic”,
“PointType”: “Float64”,
“DigitalSetName”: “”,
“EngineeringUnits”: “”,
“Span”: 100.0,
“Zero”: 0.0,
“Step”: false,
“Future”: false,
“DisplayDigits”: -5,
“Links”: {
“Self”: “https://[SERVER]/piwebapi/points/[WEBID]”,
“DataServer”: “https://[SERVER]/piwebapi/dataservers/[DATASERVERWEBID]”,
“Attributes”: “https://[SERVER]/piwebapi/points/[WEBID]/attributes”,
“InterpolatedData”: “https://[SERVER]/piwebapi/streams/[WEBID]/interpolated”,
“RecordedData”: “https://[SERVER]/piwebapi/streams/[WEBID]/recorded”,
“PlotData”: “https://[SERVER]/piwebapi/streams/[WEBID]/plot”,
“SummaryData”: “https://[SERVER]/piwebapi/streams/[WEBID]/summary”,
“Value”: “https://[SERVER]/piwebapi/streams/[WEBID]/value”,
“EndValue”: “https://[SERVER]/piwebapi/streams/[WEBID]/end”

Hello @jouni.karppinen,

Checking with the developers this might be an issue in the latest (v2.6) release. I recommend using the V2.3 release for now, this was our last most stable release. Once 2.7 is released release you can upgrade to this version. It is expected to address both of these issues and is expected some time next week.

You can download older releases here.



I did the downgrade to V2.3 and for a moment it looked good.
4 requests to get WebID from PI WebAPI went through until Connector errored out with stack trace rows in real time logs looking a lot similar as with v2.6

After reboot Connector gets stuck in loop with
“Initializing tags”
“HTTPS request is: https://[PISERVER]/piwebapi/dataservers/[DBWEBID]/points?nameFilter=[TAG]”
lines repeating

Scheduled actions log shows “http connect errors” once every minute, even though 4G connection has been established.

We might give it a one more go with V2.7, I hope it comes out soon.


Hello, I will pass this along to the developer. In the mean time lest see if we can verify the connection to the server from the ewon. Can you provide a backup with support files for me to review? You can take this we Ebuddy.
Can you also run the following script in the BASIC IDE replacing the IP address in the example with the IP or host name of the server.

You should be able to copy paste the code into the init section then in the console run ping.


Backup and support files sent in PM.

For some reason PING does not work, I have tried it before and it reports failure even when connection has been verified to be up and running. This is most likely caused by the 4G VPN tunnel and our firewalls & routing rules.
In any case, after downgrade to 2.3 we did see calls from Flexy for a little while so the connection should be OK

I noticed version 2.7 has come out and gave it a try.
Problem remains and seems to relate to 4G being very slow to establish a data connection.
It takes about a minute for connection to come up after boot.

Hello, your logs make it look like none of the requests finished successfully. I suspect this is an issue with your certificates. If not, there is some other connection issue causing this.

You can restart the OSIsoft connector using ANT build and the build.xml file on github.

Do the responses take more then 2 seconds to get back to your device? HTTPS timeouts are set to 2 seconds unless you add in an additional parameter to the appConfig portion of your configuration json file.

Double check the certificates and to be sure there is no connection issue I would open up wireshark on your OSIsoft server’s machine and look for the incoming requests.

I recreated the certificate following the steps described in Certificates-section in Github.
Unfortunately that did not help and we are still stuck with this problem.

You mentioned PING doesn’t work. Can you set up wireshark to make sure requests are making it to the server?


Were you able to make any progress verifying the requests? I can help you get a wireshark capture if needed.


Work on this issue is on hold for now as we are considering moving to OPC UA.

Hi jouni,

Let us know if there is anything else we can help with.