Power up issue Anybus X-gateway


#44

I am investigating what info we can get from those logs. They are pointing towards some of the lower level C application running on the system and i am not sure if it will help.

I believe investigating what is common among the setup having the issue might be a better course of action. Once we know what they have in common it should narrow down what is causing the issue.

Deryck


#46

Hi Deryck

I did some more testing this morning. I unplugged the Profibus cable on the gateway and I had it running on the slave side on EthernetIP only. The remaining devices on the EthernetIP network were the Anybus gateway (adapter) and a Fanuc R30iB Mate controller (scanner). On the Fanuc controller I had a program running that every 32s was sending a reset (over the control word) to the gateway. During the 4h test I had 6 lock-ups on the gateway. Every time it happened it was frozen up and only cutting the power would recovery from it. I hope this information will help to recreated the issue in your test lab. Thanks


#47

Hi @astoneye

This might be help full, let me set up the same thing and see if I run into the same errors. It might take me a few days to write a test program.

To make sure my device is setup like yours and also test if the Profibus config plays a part can you share a copy of your setup from Anybus Nettool for Profibus?

Deryck


#48

Hi Deryck

Please see the attached Profibus configuration we are currently using on the Anybus devices.

Thanks

Best regards,

AnybusConf_50.xml (4.52 KB)


#49

Hello,

I didn’t get to test this last week I am working on testing it either later today or tomorrow.

Regards,
Deryck


#50

Hello Astoneye,

Can you please send me a copy of the si018070V2.gsd. I need this to open the project.

Deryck


#51

Hello Deryck

Sorry for getting back to you so late. Please see the attached file and let me know if you need anything else.

Thanks

si018070V2.gsd (27 KB)


#52

#53

Hi,

Thanks for the file, I downloaded your config and am running a test to see if I can read data off the device after reboots.
To make sure im testing the same situation you are seeing here:

What do you consider lock ups? Are you saying the entire device locks up? The test I am running is using modbus requests over ethernet/IP but I am expecting similar results and to not be able to read data. I ran it for 5 hours yesterday and never ran into an issue. The test rebooted the device ~1000 times with out issue.

I would like to see if the script catches the error you are seeing. Let me set it up to be more automated and I will share it with you. It should only require you to install python 3 and then run the script.


#55

Hello,

I haven’t had enough time to work out all the bugs in my test so it does not run as graceful as I would like. But what it is doing is cycling though reading values off of the device and then rebooting it. If it does not reboot the read requests will fail.

To run it you will need python 3 installed on your PC. You will also need to open the file in a text editor and update line 5 replacing the IP address with your gateways IP address. You can also update the number of times it runs the reboot by changing the test_iteration variable and how long it waits to reboot the device again with the delay_time variable.

controlwordrebootloop.py (2.5 KB)
To run the script you will need to navigate to the directory in CMD then enter py controlwordrebootloop.py

Let me know if you have any questions.

Deryck