Problem staying connected to DreamReport web portal using M2Web


We setup a DreamReport web portal and we want to access it throught M2Web.

When connecting with eCatcher, we can access our web portal without any problem. But when we tried doing the same while using M2Web, it is not working.

Sometimes the web page stay blank. Sometimes, we succeed at reaching the login webpage and after logging in, we get redirect back to the m2web login page. Sometimes we even get error message before being redirected to the m2web login page.

Does M2Web supports web portal and if so, do you have any clue of what we could do to be able to connect and stay connected to the web portal while using M2web?

To be noted that the web portal is built using “DreamReport” application and use asp web page and thus, we don’t have much control over the code behind the web pages.


Can you further explain how the DreamReport web portal is set up? What is it running on? A web server on the eWON’s LAN?

How is it accessed? I assume HTTP or HTTPS? Are there any other technical details you can share about it?

Hi Kyle,

The DreamReport web portal is setup on a pc using IIS with the HTTP protocol on port 80.

When connecting throught eCatcher, we can access this web Portal using this address : I’ve hide the name of the client as I’m not sure if I can share it publicly.

When connecting to the web portal, m2web seems to use a proxy because the address changed from “” to “”.

Also, I looked at the network traffic on the web page and here are some of the errors I got on the web portal :

Let me know, if you need anything else.

Thanks for the help and have a nice day,

It looks like there may be features in DreamReport that don’t work with the way M2Web uses proxies or web sockets. Unfortunately, this isn’t uncommon. I am not a web developer, but if you can get me as much information about how the DR web portal works and logs of the interactions as possible, I can pass them on to the developers to take a look. I’d also recommend reaching out to DR support to see if they can help in any way.

One thing I would try in the mean-time is making sure that RTEnTransFw = 1 in the comcfg.txt

Thanks for the quick reply. I’ll do my homework and come back to you with more info.

We already reach out to the DR support and are waiting for an answer on their part.

In the meantime, I’ll look into the config parameter you point me too.

Thanks again!

So I’ve test the parameter you point me to and it was disabled but even by enabling it, it does not solve the issue.

Here a list of things I found so far :

OK. I will escalate this issue and see if the developers can advise something. I tend to think there is some code that is required to run on the client and it isn’t supported over M2Web, but I’ll see if they have any ideas.

It is to be noted that DreamReport can be tried for free (there is no evaluation period) and it comes with a demo (which I use as is for my office setup). So if your technicians want to replicate the scenario, they can do so.

Your help is greatly appreciated.

Great - thanks for letting us know! I’ll see what, if anything, can be done to make this work for you.

Do you know if the Web portal uses Java Applet, Active X or Dynamic link? If so, it won’t work with M2WEB, but you can use the Ecatcher mobile app.

Do you know if the Web portal uses Java Applet, Active X or Dynamic link?

I’ll have to ask Dream Report team directly as their manual do not contains this information.

but you can use the Ecatcher mobile app.

We have a Talk2M PRO account and would like to benefit from the “unlimited number of M2Web sessions” feature that comes with it. This is one of the reason, we would like our customer to use M2Web platform. Does the Ecatcher mobile app offer the same unlimited number of sessions or would we need to increase the amount of concurrent connections?

M2Web and eCatcher Mobile are both unlimited with Pro:

M2Web and eCatcher Mobile are both unlimited with Pro

Good to know. For this to work, I would need to restrict the access to these users to the mobile app only. Is there a right that exists that allows a user to only connect using the ecatcher mobile app but not the ecatcher pc version? If so, I can’t seem to find it. I have the 6.5.2 build 29309 version of eCatcher installed.

Ecatcher group rights

Yes, it’s the same as M2Web because access is essentially identical between M2Web and eCatcher Mobile:


Something does not seems to work properly for me because when I only have the “Connect to Ewons using M2Web” right, I don’t see any ewon devices on the ecatcher mobile app. As soon as I check the “Connect ot Ewons using eCatcher”, the ewon become visible on the ecatcher mobile app.

I would have like to send you a picture from my phone, but security policy deny me from doing so.

No, it’s my fault. You need to enable eCatcher to use eCatcher mobile. Sorry about that.

Do you think HMS could at some point add a new right to separate the access of the eCatcher pc version from the eCatcher mobile app? I don’t really want our customer to connect on their ewon using eCatcher pc version if it used one of our concurrent VPN connection.

Hi Kyle,

I received the answer from the DreamReport suppor team.

Here’s our question :

From what I understand, you can access the Web Portal only in the LAN of the PC where it was set up. Is that right?

Is there any way to access it for example from a home personal computer outside the business LAN?

Also, does the Web Portal uses Java Applet, Active X or Dynamic link.

I ask you this question because I wanted to used a third party software to be able to access the Web Portal from my computer at home but this software doesn’t supports these.

Here’s what they had to say :

There are several ways of accessing DR Web Portal from outside your network, e.g. using “port forwarding” or VPN.

As for the second question: our Web Portal doesn`t use any of these technologies.

Any clue of what we could try next to make it work with M2Web?

If you can get me access to it with a temporary eCatcher account then I can take a look.

I’ve send you a private message with the info.

Let me know if you did not received it.