Proxy Settings for WAN to LAN


Hi Jim,

Here are the additional settings to check:

In COM config:

NATITF - (2)
WANITFProt - (2)

I think you have all the Proxy settings:
ProxyEnabled 1
ProxyProto 1-UDP 2-TCP 3-FTP
ProxyExtITF 0 (WAN)
ProxySide 1 (WAN to LAN)
ProxyPort 12345
ProxySrvPort 67890
ProxySrvIpAddr (LAN IP of device)

Let me know if these helps at all.


eWON Cosy 131 Port Forwarding Proxy with RSLinx

Cosy EC61330_00
Serial Number 1826-0614-22
Firmware Version 13.0s0

I am attempting to use Port Forwarding / Proxy settings such that a PC that will be DHCP on the WAN side can have RSLinx connect via the Proxy settings.

I have 2 WAN ports configured.
One is connected to Network via DHCP and works with Talk2M and eCatcher fine.

The second WAN is connected to my laptop with RSLinx. The laptop is set up for DHCP and has an IP in the same subnet as the Cosy. I can also ping the Cosy IP

I am not able to get RSLinx to recognize the PLC on the LAN of the Cosy
ProxyEnabled =1
ProxyProto1 = 2
ProxyExtITF = 0
ProxySide1 = 1
ProxyPort1 = 44818
ProxySrvPort1 = 44818
ProxySrvIpAddr1 = (ip of EN2t module in PLC rack)
the LAN IP of the eWon is set to and this is configured in the PLC/EN2t as gateway address.

I get yellow question and red x display in RSLinx

I was using this as a test as I would like to try same setup with a Panelview



Hi Jim,

Was this resolved? I know you mentioned using 2 WAN ports in the last post. Keep in mind that only one WAN port can be active at a time. Having a second WAN port is only for backup.