"Quote Too Long" Error on Flexy BASIC IDE

Hey There,

Here’s an issue I’m running into, I can’t find any documentation on this anywhere. Any suggestions?

It may just be that the string is too long, can you try breaking it into two string variables and see if you’re still getting that error?

I do get the same error, even when I follow my same structure as the variables above it:

Not working:

Working per usual:

Can you make me a temporary user on this account and pm me the login information

Please made this private:

[information redacted]

To start with, I’d recommend moving the code in the cyclic section to Init section because this has been known to cause a lot of issues as it will run every processor cycle and depending on the code in there, it can be a lot for the device to handle.

But before going further, was all of this code working before and a newly added section seems to be what’s causing issues?

All of the code was working before, yes. The “WriteRecord3” label and it’s relevant tags are basically the only new portions. At the top of the program I’m forcing it to go to WriteRecord3 just for testing purposes, but normally it is triggered.

The quote error shouldn’t be there anymore but it looks like it doesn’t like how you’re naming your files right now. Can you take a look at that section again and maybe check the section for how filename3$ is created?


What did you do to remove the quote error?

For creating filename3$, I do it the exact same way that I create filename2$ and filename1$.

In all situations I use the @FirstThree@ function. For reference, here is filename2$:

I’m not entirely sure what the issue might be, but I tired changing the filename3$ string to just be called test and it seemed like the code ran fine without any errors. I tried printing the filename3$ and it looked like it was starting with a “_” so maybe that was related to the issue

It looks like it is all working now… I left it as filename3$ and it worked just fine. I’m glad it’s working, but want to make sure that this doesn’t happen when we actually implement it on real devices. The “_” is normal, as this data is being read from the PLC.

If you run that same original command to name filename3$ from the command line does that seem to throw the same error?

Hey Tim,

Looks like the filename3$ was never an issue, the “quote too long” was fixed by breaking up the code into separate parts.

Looks like it is resolved. Thank you!

1 Like

Thanks for the update Nick glad to hear it’s working now

1 Like