RE: communicator issues


#1

Hi Nolan;

Yes, I think that will help. I am not seeing any problems looking at the data coming out of our board with a scope probe.

Valerie


Hi Valerie,

Great, I am glad you found the meeting yesterday to be beneficial.

As for the communicator errors, are those messages coming from the RF generator or from the communicator? Are you able to run a serial sniffer on the traffic from the RF generator to the gateway?

Regards,

Nolan Hartwick


Hi Nolan;

I want to thank you again from everybody here. I think we are much closer in understanding what our task is.

I am having issues with the communicator as show in the attached file. Line 145, 316, 466 etc. These are responses from a users query.

I did slow down the baud rate to 19200 but it didn’t help. Do you know of any other setting that may help? I did not see anything obvious in the ACM that would help with this issue.


#4

Hi Valerie,

Are you still having problems that you would like our assistance with? The email we received didn’t have any attachments. What is the device model and nature of the problem or error you are getting?

Kyle


#6

Hi Kyle,

Valerie is still having issues with the communicator and reached out to me because I do not think she saw your response. Her log file attachment can be found tucked under her signature above. The file is called “logWerrors.txt”.

I will let Valerie know where to find this thread but please make sure you get in contact with her.

Thanks Kyle!

Regards,
Nolan Hartwick


#7

Hi Kyle;

Everything is working but I did struggle with the setup. We are using the communicator for EtherCat to pass serial commands and data. All data(in or out)end with 0x0A. I have the communicator setup for Master with the Query and Response both data asVariableDataObject. The quirk is: the query VariableDataObject has the End Character Visible and the response VariableDataObject is set for No Character for the Object Delimiter. Both have the End Character Value set to 0x0A. Without the setup being like this, any command that is sent from EC Engineer to the communicator, the communicator fills the buffer with NULL before sending it to our unit. So our unit did not recognize the commands because the last character is NULL, not 0x0A.
I am wondering if the Master Mode is the correct mode for us and is there are any timing setting for query that I should be concerned about.


#8

I’m sure we can help you with this. I will just need to get a copy of your current configuration file and any documentation you have on the serial device.

Is this the expected reply?

129                  3    0x53      83       S
130                  0    0x4E      78       N
131                  1    0x3A      58       :
132                  0    0x30      48       0
133                  1    0x30      48       0
134                  0    0x30      48       0
135                  1    0x30      48       0
136                  0    0x41      65       A
137                  1    0x0D      13       .
138                  0    0x0A      10       .

and you are getting inconsistent results like this:

375                  3    0x53      83       S
376                  0    0x4A      74       J
377                  4    0x54      84       T
378                  0    0x48      72       H
379                  1    0xF8     248       ø

or the “DISPLAY MODE:1” response?

Do you know if you need to use the Variable Data Object or are you expecting a set number of bytes?

Once we can see the documentation we should be able to determine if Master Mode is the best choice or not as well as the other settings.

Kyle


#9

I have the commands working now once I figured out that quirk.

Commands are variable in length.

I am worried about what will happen when a command is sent to our unit, but it takes a long time to respond. Retrying will not help as it just restarts the time.


#11

master 19004.cfg (16 KB)


#13

Sorry, but I’m having a little trouble understanding the issue. Are you sure you need to use a variable data object because it appears to be a fixed size?

What is the reason for it taking so long to respond? Keep in mind that you can change the “Retries” value and the “Timeout time.”

It would be very helpful if I had the user manual for the serial device to refer to so I can see the way the communication is structured.


#14

There are many commands, each a different length.

Here is how they are structured

For example:

“SN:?” – to query or “SN:002” to set

“AMPLITUDE:?” to query or “AMPLITUDE:100” to set

“CLAMP”

Etc.

It takes a while to respond because it is acting on the command. And the time is different for different commands. Most are milliseconds.

The response data varies also. Sometimes the response is just “OK” and sometimes it is a voltage or current value.


#15

OK. In that case it looks like you have it configured correctly. You will just want to adjust the Retry and Timeout settings to something that minimizes the possibility of sending commands too quickly or limit the frequency of commands on the fieldbus side with software, for instance.

Please let us know if you have any additional questions.

Thank you,

Kyle