RE: INpact Quick start guide


#1

Good afternoon, Nolan.

We’re wrapping up development on this project and are in dire need of the GSD generator. Any update here?

Thanks,

B.J. Boyer ** | Autonetics**
Applications Architect


#2

#4

#5

#6

#8

Hi BJ,

I apologize for the delay, I’m not sure what happened to the previous email regarding this. This email doesn’t include the screen could you resend that for me to take a look at.

How are you networked to the device you are creating a GSD file for? Is it directly connected from you PC to the device or are other devices involved?

Deryck


#9

I’ve attached the screenshot of the GSD tool error. The PCIe INpact card is in my PC. My network configuration is:

PC > Network Switch

PC > INpact Card > Network Switch

Network Switch > PLC

The switch and PLC are sitting beside my desk.

Summary of the issue:

The “HMS PROFINET GSD Generator Tool” app keeps giving me an error when I click “Scan for Modules”. See attached image. I have run the app in admin mode, but continue to get the error.

Thank you,


#10

#11

Nolan / Deryck,

While you’re looking into the GSD generator app problem, would it be possible for your to provide to us the Profinet GSDML specification?

I attempted to find it online, but Profibus.com requires you to be a member in order to download the document. I see that HMS is a member, would you possibly be able to download the spec and send to us?

https://www.profibus.com/download/gsdml-specification-for-profinet/

Thank you!


#12

Hi BJ,
After explaining the issue to a colleague he provided the following recommendation.

  1. Please ensure that the VCI example application is running on the INpact
    otherwise you can not read any GSD configuration from the INpact.
    C:\Users\Public\Documents\IXXAT\VCI 4.0\Samples\IDL\src\IDLc_TestApp_VS2010.vcxproj

  2. Unfortunately we can not send to you the GSD specification,
    you can get it only from the webpage:
    https://www.profibus.com/download/gsdml-specification-for-profinet/

  3. Here is a small quick start quide:
    "

  4. Update the FPGA & Bootloader
    using the IxxatINpactCardUpdate Tool from our webpage
    https://www.ixxat.com/support/file-and-documents-download/inpact

  5. Install the VCI V4 on the PC with the INpact board.

  6. Start the VCI V4 example application,
    that start an example ProfiNet node with some signals
    C:\Users\Public\Documents\IXXAT\VCI 4.0\Samples\IDL\src\IDLc_TestApp_VS2010.vcxproj

  7. Generate the GSD file using the HMS Profinet GSD Generator Tool
    when the VCI V4 application is running.

  8. Import the generated GSD file in to the ProfiNet master configuration software (e.g. TIA)

  9. Start your PLC application.

  10. More detailed description you can download from our webpage:
    https://www.ixxat.com/support/file-and-documents-download/inpact
    https://www.anybus.com/support/product-support/compactcom-starter-kit/downloads-and-documentation/?ordercode=0232XX
    "


#13

Deryck,

Thank you for the information, unfortunately I have already performed all of these steps multiple times.

I have used the sample app to start the driver, I used the sample GSD to load the device into the PLC, and I have been able to successfully transfer data between the PC and PLC. We’ve just completed a translation of the driver into VB.NET which is also working.

We cannot download the GSD specification from the link you provided because it requires a membership which we do not have.

Step 7 in your list cannot be performed because the GSD Generator Tool is not working which is the root of the reason I am asking for support. When we “Scan for Modules” in the tool, we get the error in the screenshot I sent you previously.

Is it possible to obtain the source code of the GSD Generator Tool? This way we can debug the problem ourselves.

We have a great need for this product – we hope to place it into every unit we ship. But if we cannot get the GSD generator tool to work and have to manually create each GSD, that will be a major roadblock.

Thank you for support.


#14

#15

Hi BJ,

I am looking into what options we might have to debug the tool. I am not sure if we can provide the source but I will ask.
Have you tried this from a different PC or using a different Ethernet adapter such as a USB to ethernet?

Deryck


#16

Deryck,

I realized there was a newer version of the GSD Generator tool available on the Anybus website. After running that I still get an error but it does have some additional debug info. Please see the attached screenshot. Hopefully this will help you resolve the issue.

Thanks,

B.J. Boyer ** | Autonetics**
Applications Architect

235 James Jackson Ave.

Cary, NC 27513

Office: 919.537.8301

Support: 919.903.9140

bj@autonetics.com
http://www.autonetics.com

anet


#17

Hi BJ,

My colleagues were just suggesting you try the latest tool GSD_Generator_1_4_3.zip (1.2 MB) This might be the one you just downloaded.

Try setting the IP with IPconfig again and see if it shows up. Also make sure you have an IP address in the same subnet. It might also be worth trying a cable directly from your ethernet port to the Inpact card.

If you are still having issue I would like to setup a webex Monday with the Ixxat Team in Germany so we can get this issue resolved a little faster. If you are still having issue let me know your availability and I will work on setting something up. Since they are in Germany this would need to be in the morning when our work hours over lap

Deryck


#18

1.4.3 is the version I’ve been using.

I tried connecting the card directly to my ethernet card on the PC. Still getting the same error. I’ve attached a screenshot showing the GSD tool error, my local machine IP address, and the IPConfig tool info for the card (it successfully detects the card and allows configuration without issue).

I’ve tried turning off all my firewalls. Running the GSD tool in various compatibility modes. Widening the subnet mask. Changing the gateway. Removing the Gateway. I’m out of ideas.

A Webex on Monday sounds good. Please send me the details.

Thank you,


#19

Hi BJ,

You should have received an invite for a webex Monday Morning.

Regards,
Deryck


#20

Hi BJ,

I have been discussing this with a colleague in my office and have a few things to look at while we wait to hear back from Andreas.

What is device name assigned to the INpact? Perhaps this name is not compliant and our tool is more picky the the PLC. Can you provide the devices identity info we can review this to see if there are any potential issues. (this should be in a header file.) You might also be able to use the Proneta tool to check the device. Another key thing to look at is the version numbers you are using are they set with string or integer values?

I also just heard back from Andreas.

  1. We assume that the problem occurs because the PCL (Profinet Master) is connected and started.
    (not the slave VCI application, the VCI application should be started)
    Please disconnect (or switch off) the the PLC (Profinet Master) when you use the GSD Generator and let me know if the problem is solved now.

  2. Please start the GSD Generator with the administrator permission (“run as administrator”)


#21

The Profinet device name is anetPnet1

Which version numbers are you referring to? If you mean Profinet Attribute 11: IM Software revision

Then it’s 99.99.99, which is being sent as 3 separate bytes:

ABCC_SetMsgData8( psNewMessage, PRT_IA_IM_SW_REV_SYMBOL_VALUE, 0 );                  // V

     ABCC_SetMsgData8( psNewMessage, PRT_IA_IM_SW_REV_MAJOR_VALUE, 1 );              // 99

     ABCC_SetMsgData8( psNewMessage, PRT_IA_IM_SW_REV_MINOR_VALUE, 2 );              // 99

     ABCC_SetMsgData8( psNewMessage, PRT_IA_IM_SW_REV_BUILD_VALUE, 3 );              // 99

I have disconnected the PLC from the network and still get the error. I have run the GSD tool in admin mode and still get the error.

I just downloaded and ran the Proneta tool. See attached screenshot.

Is it possible to get an updated version of the GSD tool that could provide additional debug information regarding the exception being displayed in the popup?


#22

Hi BJ,

I am still waiting to hear back from my colleagues in Germany regarding the Vendor ID info contact info but I was able to track this link with info.

It looks like you will need to fill out the forum provided and either email or mail it to them.

Regards,
Deryck