Reading from A/B via DF1 Half Duplex to eWON flexy inbuilt RS232 to EIP


I have an eWON Flexy 202 which has an inbuilt RS232 port. The thought is to have a A/B MicroLogix 1500 connected to the RS232 port, then have it converted over to EIP.
The communication protocols are as follows:
DF1, Half Duplex Slave, 9600,0,No Handshaking,BCC,Node Address 4.

The same configuration has been setup on the eWON, however, I have not been successfull in communicating to the PLC.

I also tried with the communication protocols:
DF1, Full Duplex, 9600,0,No Handshaking,BCC,Node Address 4.
With “Full Duplex” the communication does work, but this would require reprogramming tens of PLC’ to be able to connect with the serial port. Is there a config to get “Half Duplex” to work in eWON?

I would double check those settings on the MicroLogix. I’ve never seen half-duplex RS232 before.

Here is the configuration of the MicroLogix 1500.

It is setup like this with communication on radio, and the job is to switch the communcation over to 4G.
This communication works today so there shouldn’t be a problem I guess?

I would assume that it’s using RS485, not RS232. Have you tried configuring the Ewon with RS485 Half-Duplex?

Tried that as well with no luck. Here is the Event Log:

Did you change the serial port settings? The log indicates the port config is wrong.

Also, you need to update the firmware.

The serial port is set to “RX4xx*, Half Dup., Pol. OFF” as seen here:

I’ve also updated the firmware from 12.0s0 to 14.2s0.
Here are the settings for DF1:

Here is the SYSTEM cfg:

Event log:

Seems like “RX4xx*, Half Dup., Pol. OFF” did help a bit, but I am still unable to communicate with the PLC. For reference, I’m trying to communicate against a OPC with KEPServer and was able to do this when the communication was set to “Full Duplex”.


Does the Kepware server “speak” DF1?

But, are you still getting this error? image
If so, it’s probably not working. Have you tested it by creating a DF1 tag in the Ewon?

KEPServer does speak DF1, but it isen’t necessary here since eWON converts it over to EIP right?
Also, I would assume that the only error is on the eWON since I am able to communicate to it with “Full Duplex”.

I am not getting the error anymore on:

I changed it as you said after 19/05/2020 06:17 and there are no more errors for the physical port config.

I think you will need to check the box for “bridge EIP connection” if that’s what you’re trying to do, and that will send DF1 over Ethernet, but it’s still DF1.


I did as you asked about “Bridge EIP connection”, and it didn’t do anything. I also tried for fun to see if it had any effect when I try switching everything over to “Full Duplex” and the checkmark for “Bridge EIP connection” does absolutely nothing with the connection.

On another note, if the PLC is set to Source ID 4 as in this case:

Then the eWON has to be setup with Destination DF1 Address to 1, even though the PLC is set to 4 or the communication won’t work. As seen here:

Here is proof that the communication works on “Full Duplex”:

Have you added a connection to the Kepware server like in this example:

I tried it as you said, but I wasen’t able to make it work. Let’s say I have the eWON to IP then set the IP of Topic A to:

Would I be able to ping As it stands I am unable to ping it.

Furthermore, is that how “Topic” works? I would have guessed that it requires the Node ID of the slave it is connected to, not IP?

You need to enter the EIP path, to your PLC or Kepserver.

I’m not following, the EIP path is the eWON. In this case the eWON’s LAN IP is set to which is also the EIP path?

Also, I tried it in the previous post with I also tried to setup KEPServer with which didn’t work.
Here is also a different solution which didn’t work either. I am still unable to ping

Are you 100% certain that eWON supports DF1 Half Duplex?

Yes, but if you have it working with full duplex, why use half?

It seems that the DF1 connection to the MicroLogix is working and that the problem is the Kepware connection. I think there are 2 ways you can go about this.

  1. Use the DF1-EIP bridge connection (like a transparent bridge). Set up the Kepware server as if it was reading tags from a ControlLogix PLC over EIP.

  2. Create your DF1 tags in the Flexy and then use another protocol to read those tags, like Modbus.

If you can’t get one of these working, it may be time to work with someone over the phone/Teamviewer. Since youare in the EU, you would need to open a case by going to .