Reboot reason: Watchdog in process (eproxy)


#1

In some of our ewons we are encountering a weird problem where it seems the ewon reboots for seemingly unexplained reason. In the diagnostics this error is triggered. When searching the error code list it only specifies Reboot reason: Watchdog in process (http). Offering a solution when the webserver has been generating outputs for too long.

However, our watchdog expires on the eproxy. We’ve tried raising the http_reqto as suggested, but as expected this didn’t solve our problem.

Might this problem be related to unstable internet connections? The client where we experienced this problem the most has a very long ethernet cable running to the ewon (nearing 100m) and we suspect it might drop connection sometimes due to electrical interference at the site.

We also see this problem occur sporadically in other ewons when looking back into the history. We think it might be a temperorary unhooked internet connection or ISP downtime in those cases.

However, we’d love to actually hear what this error is about and how go about fixing it!


#2

Hello,

Can you send us a backup of the device so we can take a closer look at this issue?

Thanks,
-Tim


#4

I’ve included one in a PM


#5

Hello,

Sorry, can you make sure that the include support files is checked on the backup and send it again? Also do you know if the Ethernet cables that you’re using are shielded? The issue could be related to EMI.

-Tim


#6

Hey,

We are pretty sure the cables used are unshielded and of too low quality for the specified length (CAT 5e). Right now we are working with the client and their networking supplier to replace the cable.

On the other hand we want to try and exclude any cable unrelated issues and we are seeing these error pop up in other devices’ history. Therefore we would like a better explanation of this error than the documentation now specifies so we can make sure this error is due to a connection/cable fault.

I hope to hear from you!
I’ve send you a new backup in a PM.


#7

Hello,

One issue that I’m seeing is that it seems like there may be an issue with the SIM card

Try and remove the 3g/4g card from the device and see if it’s still rebooting


#8

The sim card issue is that there’s no sim card installed. We deliver our Ewons with the module installed as backup in case a client might need it. We see this warning only when it is rebooted by other factors. Our ewons are except for a few exceptions all connected through ethernet.

Of the 35 machines installed with sim card module and no actual sim card inserted this is the only one showing these problems (constantly rebooting after around 15 min) All the others are fine. Therefore we think it very unlikely this is the problem.

We’d like specifically know more about the error: Reboot reason: Watchdog in process (eproxy) is there any additional documentation we can get on this error?


#9

Hello,

I just heard back from our colleagues in Belgium and they said they haven’t seen this error before. One thing they suggested was updating to the 13.0 firmware. Can you give me a call at 312 893 5636 to take a closer look at this when you get the chance? Or can you give us a time when it would be good to call you?

Thanks,
Tim


#10

Sorry for the late answer, our client has detected they have a loose contact somewhere in the WAN connection. However, they now have fixed it, but we’re still seeing reboots almost every 15 min exact.

For now it has been decided we are going to try and replace the unit and see if that fixes the issue. The unit thats now being used will come back to us so we can have a look in our workshop.

Regardless, I would still like to coorperate to find the root cause. Might it be possible for me to contact your colleagues in Belgium directly? Since i’m in the Netherlands this would smoothen communication.

Also is it safe to do the firmware update while connected through ecatcher? The ewon is in germany and for now we’d rather not risk taking it offline. Moreover, if someone needs to do it on location we’d rather just replace the unit and analyze it back in our workshop.


#11

I just talked with some colleagues over in Belgium and they said you can just send an email to: support@ewon.biz and they’ll take care of it.

You should be able to do a remote update when you’re connected through eCatcher and the device will come back online after the update is finished. However we do recommend that people have somebody present when updating units if possible in case something goes wrong.


#12

As might be a bit obvious from the error naming, the culprit seems to be the configured ethernet proxy which routes some traffic from our machine network to a public server. This routing has never worked on this particular machine as far as I know. Therefore turning it off (it’s non essential traffic) temporarily fixed the problem.

However, as to why this causes the ewon to reboot is yet unknown. there are around 6 machines exactly the same as this one. Programmed using the same backup with the exact same firmware. And this is the only one exhibiting this strange behaviour.

We will look into this further at a later time if A a firmware update will fix the problem and or if B the specified ports aren’t blocked at this clients site.


#13

Hello,

just wanted to check and see if this issue was resolved before I close this ticket,

Thanks,
Tim


#15

In m66 with external watchdog when sim is inserted module is restarting, please help us


#16

Hi,
In m66 with external watchdog when sim is inserted code is restarting, help us


#17

Hi,
we are using m66 module we are using external watchdog, when sim is inserted code is restarting. can you help us


#18

Hello, What is this M66 Module in reference too? Can you please elobrate on the problem on hand?

Are you working with a Flexy? Cosy?