Relay.talk2m issues

I use the in SMTP settings. Today for some reason certain emails or sms messages won’t go out. Is anyone else having troubles with this today?

My Code
$EmailTo$ = “recipient info here”
$EmailCC$ = “”
$EmailSubject$ = “8am Report”
$EmailBody$ = “”
$EmailBody$ = $EmailBody$ + “=======================” + CHR$(13) + CHR$(10)
$EmailBody$ = $EmailBody$ + "Today’s Roll Count " + STR$ DailyRollCount@ + CHR$(13) + CHR$(10)
$EmailBody$ = $EmailBody$ + "Downtime minutes " + STR$ DailyDownTime@ + CHR$(13) + CHR$(10)
$EmailBody$ = $EmailBody$ + "Average Roll Time " + STR$ AverageRollTime@ + CHR$(13) + CHR$(10)
$EmailBody$ = $EmailBody$ + "Time: " + TIME$ + CHR$(13) + CHR$(10)
$EmailContents$ = $EmailBody$
SENDMAIL $EmailTo$, $EmailCC$, $EmailSubject$, $EmailContents$
SETIO “TSbit”, 2

What I have tried;
-Originally had “recipient info here” set to a mms “**********” and has worked historically
-Tried “recipient info here” set to gmail, didn’t go through
-Tried “recipient info here” set to custom domain email and it works

I use the TSbit just to verify this section of code is running, I manually change the value when I try something new.
In the scheduled actions I can see the send mail status was a success each time.

Any advise? I have read in other forums we could change to a different SMTP relay but I wanted to ask before doing that. Thanks

Hi Dan,

Is this issue just happening to you today or has it been happening for a little while now? I’ve heard of some people having issues last week with our SMTP relay and wanted to check when the last successful email you sent out was?

Also are you getting any error messages in your code and does the


I tried using
● SMTP Server Address:
● SMTP Server Port: 25
following KB-0045-0-EN-(eWON Email and SMS Relay) (Working Copy) Page 3/6
and I get this error
uact-SMTP Server returned an error (SMTP Rep:5.7.1 : Client host rejected: Service no longer available: KB Ewon ssh-04…)

any advice?

Can you send me a backup.tar file of this device with the support files included?

I am pretty sure is not working. I got our IT that manages our domain to enable SMTP, which is a google domain. If I change the SMTP setting to the same code works. The minute I change to the messages stop coming through. In the Scheduled actions the sendmail shows success.

If you look through the logs you will see some errors, because I have been troubleshooting this for awhile and I have tried lots of different settings.

We have been having issues with being blocked by a lot of email servers and the development team has been looking into a solution for this. I was looking at the Basic IDE section of your device and it seemed like there was a lot of calls to sections that didn’t exist.

If the emails were working earlier, the issue is most likely part of the SMTP errors recently.

I am curious what section doesn’t exist? I wonder if the file I uploaded was correct.

That’s strange, when I pulled it up, I was only able to see this in your Init section:


Other than that everything looked normal

Strange. Thanks for your assist. We will just stick with the third party SMTP for now, we have done extensive testing today and everything is working smooth.

Ok sorry about the issues with this, we’re trying to get it fixed as soon as we can