RMA required for Cosy 131

Having issues with a cosy 131. The PWR led is green and USR led is steady red.

Have tried level 1 and 2 factory reset without success. During the reset, the Bl1 led is green and then goes off. the USR led becomes solid RED. Never blinking.

Have also tried recovery and firmware update through eBuddy using the serial number ( 1810-0723-22 ) without success. the LAN Leds will blink during a reboot and then stay off no matter if I try to connect directly in port 1 of the cosy or through a 10/100 switch.

Have tried to troubleshoot with our distributors technical support ( Lumen from Québec, Canada ) and they told me to request an RMA.

Thanks for you time

Simon Allard
Contrôles Gilles Leduc Inc.


Please see the RMA process highlighted below:

Hello Team,

Can somebody work with the customer. They seem to have a dead unit.


Simon-Julien Elie

Canada Sales Manager

HMS Industrial Networks Inc

Helo Simon,

Have they reached out to you regarding this issue?

I did post the information regarding the RMA. IF the device is not booting correctly, the RAM may be comprimised.


Yes, they’ve reached out to me. I guess you will send him an RMA?


Support doesn’t have the ability to fulfill RMA devices.

Have they contacted their distributor?


Can you give me a call on my cell?


Bonjour Simon,

Est-ce qu’il y a du nouveau dans ma demande? Je n’ai reçu aucun appel/courriel du support technique.


Simon Allard

Intégrateur de Systèmes Automatisés

**Spécialiste en Automatisation