S7-400 Series CPU and Anybus AB9007-B Order Number Conflict

ab9007-b

#1

Hello,
I am attempting to connect an AB9007-B gateway to an S7-400 410-5H CPU using PCS7 8.1 but I am receiving the error “different order numbers detected”.

As you can see from the image, the configured module is “Anybus X-gateway Modbus-TCP” and the installed module “X-gateway Modbus-TCP”. I chose the GSD option with PDev disabled, this matches the setting in the AB9007-B. I downloaded the GSD file from this link. When reviewing the GSD file I see that order number, in fact, is Anybus X-gateway Modbus-TCP.

I can not stop my CPU for another year, I need this gateway to function as it transmitting needed data to the DCS. A solution I am thinking of is to change the order number in the gateway, which seems unlikely.

Any help will be appreciated.


#2

Hello,

I noticed the unit is one firmware revision behind. I do not see a reference to this change in the release notes of the firmware, but I think it is worth a try to update the firmware. You will find the firmware file, software to perform the update and instructions on the link you provided. Here it is again,

https://www.anybus.com/support/file-doc-downloads/x-gateway-modbus-tcp-specific/?orderCode=AB9007

Is this preventing you from having a PROFINET connection? When is your last chance to make any changes?

I am going to escalate to see if this has occurred before.

Best regards,
Nick


#3

The documentation is lacking on how to connect via USB.

With that said I connected via USB, attempted the download but it failed. I believe the gateway is bricked now, it will not power up.


#4

I apologize, that certainly should be in the document. If you try again does it respond to the Firmware download TP at all? If you would like I can connect over teamviewer and try to fix it? If you would like to do this please private message me and perhaps we can connect first thing tomorrow?

Best regards,
Nick


#5

I was able to power the device back, the power supply feed had a blown fuse.

I can connect using the firmware software and select the file, but when I press Start to download, the status reads “Waiting for ABX to be booted…”. I tried rebooting the gateway but the download fails. I tried the download again, waited about 15 minutes but it still says “Waiting for ABX to be booted…”.

Any suggestions?


#6

Hello,

You did the correct thing, you are supposed to power cycle the gateway. When the gateway is connected to your PC using USB and you go to windows device manager do you see the X-gateway under your COM ports?

As I indicated before, I would be happy to jump on using teamviewer if you would like. Please let me know if this is something you would want to do and we could organize it through private messages.

Best regards,
Nick


#8

I have the same problems. My hardware is S7-400 412-5H, i am using PCS7 V8.2.
i am facing same problem.
i did all configuration in both side.
firmware upgrade failed just like “alsipeng”,s case.
How can I turn the gateway into a usable device?
best regards


#9

Hello @shahrooei.arash,

I recommend trying the Firmware update again. Make sure you follow the instructions in the help menu.
Due to your location I would also suggest creating a ticket in our support tool. https://www.anybus.com/support/contact-support This will put you in contact win engineers in your local area.

Deryck


#12

Hello,
I am having the same naming conflict. Tried to update the firmware on the module following the instructions but cant get past Power cycle step.


#13

Keep in mind that when the Firmware Download TP says “waiting for reboot” you need to manually power cycle the device and the file you are going to want to choose is going to look like this:

FWP_ABX_ETNM_PRT_2PS_V_1_13_01.fwp

Are you getting any errors?