Sending Control Commands to Samsung NASA via Modbus

Hi Team,

Good Day, trust you are doing good.

Please note that I am using a INMBSSAM016O000 Protocol Translator for Samsung NASA R1/R2 to Modbus converter respectively.

Initially, I got the scanning issue for which I raised a ticket and the issue got solved, based the instructions/suggestions given in the thread link below.

Now I wanted to control the individual Indoor Units from Intesis software. I sent commands to the Intesis module via Modbus to switch on/off the indoor units using FC 6: Preset Single Register as shown in the picture below. Unfortunately, an am getting the following exception when sending commands to the VRV.

"Error: Modbus exception 2"

As you can see from the Intesis Slave Viewer, getting Err: 134 from Slv: 1

I don’t know what I have been missing out. Grateful if you could please extend your support.

Thanks for your help,
Best Regards,

Hello,

Modbus Exception Code 2 means the data address received in the query is not an allowable address for the slave. More specifically, the combination of reference number and transfer length is invalid.

The TX Error 134, means that the slave device is busy and try the command later.

From the error below, it looks like that address is Read Only.

Have you tried the same command on a different AC unit?

Hello,

Has there been any update on this issue?