Sharing data between 2 Flexy using FTP

Hi I am trying to send tag data from Flexy 1 to Flexy 2 and I’ve done the setup as per this link

but i am not on a LAN network as the 2 Flexys are in different location. Both have a 4G card with a sim that enables access to my private WAN, and both have the same IP range. I can get the transfer to work on LAN but not on my WAN, any advice would be much appreciated.

Hello @Jeen,

It looks like you might need to allow access to to the ewon from the WAN. You can do this but it removes the firewall on the Flexy, opening it up to attack. I would only recommend this if the ewon’s WAN is on a private network. This is done by setting WANItfProt to 2 in the com.cfg. ssh-0050-00-en-ewon-comcfg-txt.pdf (

If they are connected to talk2m you could use the following doc to share data with the m2web api.

Sharing Data Between 2 Flexys.pdf (491.3 KB)

Hello Deryck,

Many thanks for the reply. The WAN is indeed within a private network, and WANItfProt is already set to 2 in comcfg.txt. Is there any proxy setting that needs to be done?

If the WAN protection is disabled you should have the same access as seen on the LAN. Are you able to ping the WAN IP and access the webpage?
Another setting I over looked, but could be blocking the ewons from sending the request would be VPNRedirect. Make sure this is set to 0 to allow traffic outside the VPN.

Yes I am able to access the webpage/ping the individual Flexys and VPNRedirect is also set to 0.

I’ve tried using OPC UA to communicate with the server previously and had the same issue (LAN works but not WAN), and I had to change the PPP incoming setting under the Proxy menu, is there something similar to be done?

This should work directly, Is your PC connected to the same WAN network? Are you able to open the FTP from your PC?


Hello Jeen,

Were you able to resolve this issue?

Hi Deryck no, not able to yet. Pc is indeed on the same wan but I have multiple ewons with default lan ip on the same wan, so I can’t open the ftp page through wan

You should be accessing the ewon via the WAN IP if you are also connected to the WAN. Is this not what you are doing? The LAN is a separate network. Devices all on the same network should have unique IP addresses.

I can access the flexys from my computer using the wan IPs. But can’t get them to transfer data between with each other

What IP are you using on the flexy for the remote flexy IP address? This should be the remote flexy’s WAN IP.

Yes I am using the flexy WAN IP. The 4g service provider uses a separate ip range from my private wan, there is a nat ip range that is not visible to the service provider. The nat is configured in my firewall.

Eg service provider is and mine is the Flexys will only need to communicate on the 192 layer, is that correct ?

I’m not exactly sure here, I’m not sure I understand how the service provider handles this. I was assuming the WAN IP of the flexy’s are in the same subnet and can reach each other directly. I am not sure if this is the case if a NAT is used.

When the flexy tries to open the FTP connection it will look up in its routing table how it can get to the set IP. This should cause it to sent the message out over the WAN network.

Hi Deryck,

Yes they are on the same subnet, and I’m told that they can reach each other directly.

How should I configure the routing table ?

Can you clarify exactly what process you are following in the topic you posted in your first post? Are you using the FTP option?

With the WAN protection disabled the ewons WAN interface should have the same access as the LAN. Can you follow this basic example to verify that the devices can reach each other?

Perform a PING function with Basic | Ewon Developers


I am following the FTP option as the devices will not be able to access the internet, only the WAN.

this is what i get when trying to ping the flexy from another flexy. For some reason they are unable to reach each other through the WAN?

It looks like the ewon is not able to reach the other. Could you provide a backup of the devices? I would like to review their configurations to see if we could be over looking something.

Here they are, i am simply sending 2 parameters from Flexy 1 to Flexy 2.

Hello Jeen,

The config files don’t match how i had understood your setup. I though you said the device were using a flexy modem like a FLB 3205 and the wireless network they were connecting to were on the same subnet. It looks like your devices are connecting via the Wired WAN connection. The calls you are making seem to be directed at the VPN IP of the device.

Looking at the error logs it looks like the flexy1 might not even be getting a internet connection.

Can you please provide a backup of the device using ebuddy, with the “include support files” box checked. This will make it significantly easier for me to look over.

Can you provide a clear description of how the devices are configured? How is the LAN setup, what WAN interface is enabled, Is this the interface you are trying to reach with the remote device? Are the WAN interfaces in the same subnet?

Hi Deryck,

Both the Flexys has a sim with a static IP and internet access, only an APN into my private network. In our current testing phase they are all connected to a switch for convenient config on my laptop (instead of plugging in and plugging out constantly), but when deployed they will only be connected through WAN. The WAN interfaces are in the same subnet.

When you say this ->The calls you are making seem to be directed at the VPN IP of the device.<- by this do you mean the IP of the FTP? I will try to get the files when I can, the Flexys are not currently with me. However i did do the the backup through ebuddy with the support files and attached it in the previous post.