Sinema RC openVPN server trying to connect to ewon devices issues

Read a lot of post to see how to establish vpn tunnel between Siemens openVPN solution called Sinema RC and ewon devices.
At this point the error I get is : Options error: You must define TUN/TAP device (–dev)

Tun is set into ewon device and into the ovpn file which as been ftp into usr folder like stated.

What else I need to do ?

Thank you

I have not see ewons used with Siemens open openVPN solution. Is the Siemens openVPN a VPN server?


Yes, based on linux openVPN.
Setup is done and working with siemens openvpn and ipsec devices. Siemens just add a graphical interface over the openVPN
I’m trying to find a ovpn template file to compare and see what kind of settings I must change to make it work. Looks like the only error I got so far is about the TUN settings which it is set into the ovpn file and into ewon device but still getting the error…

You should be able to connect a Flexy to a OPENvpn server, but that typically falls out side our standard support.

We do have these instructions for connecting to a PFsense OPENvpn server. I would expect this to be the same process. Using pfSense as OpenVPN server for Ewon Flexy

How to setup pfSense to act as OpenVPN server for Ewon devices.pdf (345.6 KB)

Hi Thank you for the document but I went through it and pfSense doesn’t seems to use openVPN client.ovpn config so it is not helpfull in my case.

Do you have a ovpn template file that I could use and compare ?

I think the info you need is here:

1 Like

I use the opvn provided with the required config for my setup and still getting only one error which is still :

Options error: You must define TUN/TAP device (–dev)

Where are you seeing this error?

in the real time log from the ewon

Make sure VPNDrvMode = 0 in comcfg.txt.

Yes it is set to that since the beginning of my testing

Please share your client ovpn file with us.


And the value of VPNCfgFile (in comcfg.txt) is ‘+/usr/Ewon_test_Maison.ovpn’ and it’s in the right directory?

yes it is, including the “+”

Please use eBuddy to make a backup of the Ewon and check “Include Support Files” and send that to me so I can check the logs and config.


I’m not sure why it’s not picking it up, maybe it doesn’t like your formatting…


Can you try formatting it like the example?

Tried that and still the same error on the ewon device:
Options error: You must define TUN/TAP device (–dev)

I read on another post that we need to remove the line : persist-tun so I tried it and still same issue.

Have you tried taking the + symbol out of VPNCfgFile:+/usr/client.ovpn ?

If that doesn’t work, you may want to reset the device and try setting it up using a very basic .ovpn file, as close to the example as possible, to see if you still get that error.
example.ovpn (242 Bytes)