SLC 5/05 to MODBUS (AB7072) - EEM Writing not working

Hi there - I need some technical assistance.

I have a SLC 5/05 that is able to connect / read from an AB7072.
I’m having difficulties writing to the output area of the selected node.

A fairly simple application - trying to read 36 words and write 24 words.
Followed the configuration example and EEM setup instructions in the application note titled
"Using a HMS Anybus Ethernet Communicator with an Allen
Bradley SLC 5/05 Controller"

Not sure why I’m having difficulties with the writing.

EEM Instruction for reading:

EEM Instruction for writing:

Configuration file is attached.

When looking at my node monitor - the Output Area is always populated with zeroes and never overwritten with the data I’m attempting to send.

Any review / assistance would be greatly appreciated!



18NOV2022 - TEST_3.cfg (16.0 KB)

Screenshots above show a disparity between the 36 words read in the EEM instruction and the 24 word setup in the configuration file. My mistake - but not my issue.

For clarity, the issue lies only with writing from the SLC 5/05 to the AnyBus.
No errors are present within the PLC software and the write EEM instruction is able to execute successfully. It’s just not sending the data (rather important).

The data file that is being transmitted has several non-zero values:


You have to disable the run/idle header if you aren’t doing a Class 1 IO connection. Otherwise it’s going to time out and clear the data.

Thanks Kyle - appreciate the reply. I’ll head in to try that now and update shortly. …Mike

Kyle - that seems to have worked for me!!
Thank you for the reply and the details - a great way to end the week.

Have a good one,

Maybe I responded a touch too quickly…

I noticed that now the READ EEM is not updating as expected - the written data has updated within the AnyBus InArea (as can be seen in the screenshot above) but the data is not transferred to my EEM message and is no longer updating to the PLC.

Strange - any ideas?

OK - a bit of an interesting development…

I had my ladder set up to read continuously and only write on a data change.
When I write, I now pause the “read” message, and start it after a small delay.

This works and everything updates as expected.

Thanks very much again - I believe this issue to be solved!