Some Functions of Fanuc Robot being blocked thru Cosy 131 connection

I have a vendor that connects remotely to service a Robot. The process is, He connects though the eWOn and then he opens a Web page interface on the Robot and performs admin actions. If he on site it works fine. However, when connected through the ewon most of the advanced features do not work.

Could the ewon be blocking certain ports?


The eWON forwards all ports.

Are you using the eCatcher software to connect to your device through the eWON?
If so, the software may be using broadcast messages which are not allowed through the VPN tunnel by default.

You can enable broadcast messages through the VPN tunnel by following this document:

I made the changes and it still does not work.

The vendor opens the ecatcher and connects to Talk2m, he then chooses the ewon and clicks connect. Once the connection is made, he minimizes the ecatcher screen and opens an IE page. Then enters the IP of address of the Robot’s controller. The Controller has a built in Web Interface. This opens a Fanuc Webserver interface. Then he clicks on Remote iPendant. This is where it stops.

Fanuc has said “We see that Robot Initiates a connection to the Foreign Address via the 3002 Port to 55971. We suggest having the eWon Cozy VPN Interface allow all messages out originating from 3002.”


We forward all ports in the range you listed (3002 - 55971).

As a next step, I’d like to try disabling our PlugNRoute feature in the eWON. Sometimes this feature will cause connectivity issues with other devices and a colleague of mine suggested disabling this for FANUC products.

If we do disable this feature, it will require that your device has its default gateway set to the eWON’s LAN IP to communicate.

To disable PlugNRoute in the Cosy 131, see the instructions below:

(Instructions for firmware version 12.1s2 or earlier)

  • Navigate to the interface of the device
  • Go to settings / Maintenance
  • Enable the checkbox that says ‘show advanced options’
  • Click edit com configuration
  • In here, search for the parameter NATITF
  • Change the NATITF parameter to a value of 2 and then click save
  • Reboot the device

Once the device reboots, you should be good to test it again.


Did disabling the PlugNRoute feature in the eWON resolve the issue? If not, any updates?

I do not know yet. I am waiting on the Vendor to test the connection.

We had the same problem and the setting NATITF parametr to value 2 solved the problem.
Our firmware version: 14.1.s0 eWON Cosy

Had another customer who had this problem and setting Natitf to 2 (In Storage > Edit COM cfg) and setting the default gateway on the robot to the Ewon’s LAN address fixed the problem.