Status word not always with no error, but retransmission warnings


I have two Anybus AB7007-C modules, that are setup the same, except for their IP addresses. They both communicate to an identical Modbus devices. Both devices are on node 1, which I think is why we have two modules. The logic to get each individual status word is exactly the same for both devices, which I created using the manual. The Byte sizes to and from the devices are identical, and setup to the same sizes using the Anybus Configurator. The problem I am having is that on one I get the desired feed back of no errors, and the other one I get alternating retransmission errors.

I get the 0x1F - No errors always on one. The other I get it alternating between the 0x1F code and 0x00 Retransmission Counter Updated, and see the counter rising. I have gone through both configurations, and PLC IO and don’t see any reason why one behaves different then the other, because they both seem to be identical.

What I do notice different is that the SR_HS_SEND feed back on the one that seems to work fine is always on, and the other alternates on and off.

My setup is master mode with the control/status parameter set to enable but no startup lock.

I tried to program in such a way to just read the status register, because I don’t need to send anything I think, but cannot seem to get it to work, and had to write to the control register to work with the below flow charts in the manual. For the control word I only use the CR_HS_CONFIRM and CR_HS_SEND to get my status, and the rest are left with a zero value.

I am quite stuck and kindly ask for some assistance, and can only think that there is somehow a difference in the anybus modules themselves.

Hi @msantos,

Can you provide the serial numbers for the two devices so I can check if there are any differences?

Are they both wired exactly the same, same bus length, etc.? Are they using RS-232 or RS-485?

Do you have a way of testing the communication on the Modbus device, like a USB-to-serial adapter with a Modbus scanner software, like Modscan or CAS Modbus scanner?

Best Regards,


Hello Kyle,

I was surprised, but they are consecutive serial numbers. A0174CF5, which is the one I have problems with, and A0174CF5.

They are setup for RS422, and are wired exactly the same. Its setup the following way:

Databits 8, Parity Even, Stop Bits 1.

I would say the bus length would be relatively the same. The machine is relatively small does not have long wire runs. And, has functioned for years without the anybus status being used. We wanted to get status from it, because we have always had allot of startup programmed alarms, that should not be happening and related to the anybus communications between the PLC and devices initial connections.

While I was getting the serial numbers I noticed I get number 5 red led on the one that works, and an alternating red and green number 5 LED on the one that cycles back and forth.

I do have a USB to Serial adapter, but no modbus scanner software. Which one would you recommend to troubleshoot? Do you want me to send you logs created in the configurator from the 2, and the config files?

Have you tried swapping just the Anybus Modules, not the cables, to see if the problem follows the Anybus or the Modbus node and cable?

Are you sure that it’s LED 5 that is alternating between red & green? That is not an option for LED 5:

I guess it could be the subnet starting and stopping, but that’s unusual.

If you disable the Status/Control Word, does the gateway operate properly?

If you have a USB-to-serial cable that supports RS-422, then I would recommend testing with CAS Modbus Scanner. It’s free and works well.

I realized I sent the same serial number, and the other module is A0174CF4.

I can switch the modules, but have to wait when production is not operating the machine, which can be a few days.

In the meantime can look at all the other possibilities?

I know the red and green are not suppose to operate together, and the alternating is happening when the sent and confirm CRs are being sent. I have tried to introduce delays between doing each one, and get the same results. When I don’t try to send and confirm commands to the control word the #5 LED works fine and is green. But, the whole endeavor is to be able to get status of the module, and nodes.

I checked and my serial adapter is just for RS232, so I cannot scan the modbus. Would me sending the log text files of the logging tool in the configurator for each module help, and maybe the configurations?

Yes, please do.

Btw, the serial numbers that you sent are for the internal Eth/IP modules, they aren’t the AB7007 serial numbers.

Those are the serial numbers i was able to get from the configurator tool about menu. I will see if i can get the model numbers from the configurator, because that is what I have been told we use on the machines, and cannot physically see the sides of them. We have 6 almost identical machines, with two of the units in each.

Attached are the log files
IP1034.txt (30.5 KB)
IP1033.txt (31.1 KB)
IP1034(1).cfg (16.0 KB)
IP1033(1).cfg (16.0 KB)

I noticed that you are getting occasional timeouts to the Read Holding Registers commands on one of the devices (IP1033):


The other one (IP1034) doesn’t show any timeouts in the log.

It’s hard to say why. The command is correct and at other times the command is being answered, so it could be a wiring issue, a problem with the slave, or a timing issue. I think the easiest way to find out is to swap the Anybus devices and see if the problem follows them or not.

As promised, below are what i could get from the anybus modules through the configurator. As the machine is working, and the IO registers communicating properly for the machines to run. I will have to wait until they are down to do a swap. I will write to you on the result, when we can do it.


That will show the serial number of the Fieldbus device (Ethernet/IP adapter), but doesn’t give the AB7007 serial number which is printed on the label. I don’t think it’s important though, as these appear to be the same model.


We finally had time, where our machine was down to swap the modules. The attached is the log IP 33, which was switched from 34, and looks to be dropping less, but still dropping out. Do you think the problems is therefore wiring/connections?

IP1033(1).txt (30.5 KB)

I’m not seeing any errors or timeouts in this log.

Can you clarify exactly what was swapped? Did the issue following the Anybus or the node/wiring? The log is called IP1033 which is the same name as the one that had problems, but what exactly is that referring to (Anybus master or the slave)?

Hello Kyle, The problem followed the node/wiring. IP1033 is a short form for the IP address of the any bus module we are using ( The log I sent today was after switching the 2 anybus modules in the panel, 33 to 34, and 34 to 33, and also switching the IP addresses on the module side. The log was after switching the two, and seeing we are still getting connection faults on the same node, and not following the anybus module to the second node.

In that case I think it must be a wiring issue or a problem with the slave.

We were able to fix the connection side, so the connection through the status information says it is continuous now. The only thing pending is that LED 5 cycles between red and green, even though the status byte says its okay . Is there anyway to figure out why the LED gives an error of some sort, and recovers?

You could continue to take logs, looking for timeout or errors or try adjusting the timing, but if it’s working, you don’t need to worry too much about the LED 5.

I do get hex 1F constantly as the status vie ethernet. I am not sure how to read the logs, but if you could check, I can log and send them again.

I have increased, and lowered the timing and get the same results. I had written the following before.

BlockquoteI know the red and green are not suppose to operate together, and the alternating is happening when the sent and confirm CRs are being sent. I have tried to introduce delays between doing each one, and get the same results.> Blockquote

The LED5 is something more for our maintenance staff, as they are used to see it green all the time. We have created an alarm indicator on an HMI, but again its so I do not get calls, because they see the red light and say there is a transaction error.

If you want me to take a look at the logs, please send them.

What happens if you disable the control/status word?

You also have a very fast update time and timeout (20ms and 80ms). I would try increasing those. You could also try a different message delimiter in the Subnetwork settings (try 10, 20, 50, etc.)

If I disable the control/status word LED5 stays Green. I had mentioned that before.

Blockquote When I don’t try to send and confirm commands to the control word the #5 LED works fine and is green.

I had changed the update and timeout times, because they were on the order of 1 second and 10 seconds before. They have to be relatively quick, because a few seconds delay can burn the material running through the machine, using the anybus communications. I can change those numbers to be less aggressive, and makes sense. I have gotten the light to stay green, more often then red, for a few seconds now. It now blips red instead of green. I did so by asking to get the status every 500 ms, instead of using just the control and status bits to decide the timing automatically.

For a 57600 bits/s communication network, what would you recommend the query timings be if I am to be communicating up to a maximum of 50 bytes from the serial side to the ethernet side? Is there a way to calculate it?