Staubli CS9 -- Issue to get in Debug mode

Our systems are equipped with eWon Cosy 131 for remote assistance.

On some systems we have 6-axis Staübli robots. With the new version of Staübli it is no longer possible to connect remotely. We have a message that a port 5656 is closed. We try to change the port number to get online, but the issue still the same.

I suppose that the eWon blocks the communication somewhere. Is it possible that something is blocking between the WAN and LAN?


There is no port restriction on the LAN side. Have you been able to ping the device when connected remotely?

Have you tried to adding the device in eCatcher?


yes I’m able to ping the device. I’m also able to connect to the controller’s vnc.

I add the device in eCatcher, but no change.

I think the controller is trying to make a bi-directional connection to my PC but can’t.

If i use a standard VPN it’s OK.
Is a possibility to connect to a eWon Cosy without using Talk2M ?

Can i get a backup with support files from the unit?

You can set up your own OpenVPN service. I have attached the guide below:

Here is the backup of the eWON configuration.

Backup.etar.gz (14.9 KB).

Thanks for the documentation, I’ll look into how to do that.


Can you get the backup with support files through eBuddy? I am unable to open the backup you provided.

Were you able to set up your own custom VPN?

Are you able to get a backup of the unit with ebuddy?

Hi Kevin,

here you have the backup file from the eWon and I add a Wireshark trace when i try to connect to the staubli controler.

eWON_Backup.tar (189 KB) Wireshark_eWon_Staübli.pcapng (136.0 KB)

I will escalate this issue, because it looks like you posted on a similiar topic back in December. Have you added the robots to eCatcher?

thank you. this is a point that has been blocking us for a while.

Yes, i add the IP adress from the robot to eCatcher. I’m able to transfer data or get online to the HMI.

It is only when we want to go into debug mode to modify the software that we are blocked.


I will create a case and escalation to verify if we have the ability to comminucate in debug mode