Subject: Ubuntu OpenVPN Server and Industrial VPN Router OpenVPN Client :


#23

Do u have your skype id that we can have conversations faster ?


#24

Hi kyle,

I have attached server log file.

How can i create client log file from ewon flexy side ?

log.txt (4.19 KB)


#25

#26

#27

Hi kyle,

Sorry for the inconvenience, Refer this file as server log file.

log.txt (1.65 KB)


#28

Gentle reminder…


#29

Sorry, I was tied up all day yesterday. I’d like to help you get this resolved today.

The server log did not contain any errors and it looks like the client connected and received an IP address, so it appears the issue is with the eWON configuration. Can you please create a backup of the eWON using eBuddy (make sure to check “Include support files”) and send that to me?


#30

Hi kyle, I have attached the backup of eWON including support files. Check and revert me if any issue is there in eWON Configurations.

Thank you in advance.

MOVED TO STAFF NOTE (240 KB)


#32

The real time log on the eWON is filled with this error:

Your client.ovpn file contains this erroneous line:

image

Try removing it.


#33

Hi kyle, I have tried with removing that but it still shows VPN Configuration is not connected.

For your reference I sent you the backup of eWON with correction.

MOVED TO STAFF NOTE (257 KB)


#35

I’m sorry for the delay. I tried to recreate this today, but was unable to. Will work again on this tomorrow-

How did you create your keys? Did you create a separate CA Server? Were you following this guide: https://www.digitalocean.com/community/tutorials/how-to-set-up-an-openvpn-server-on-ubuntu-18-04 ?

In server.conf can you change verb to 9 here :

[ Set the appropriate level of log file verbosity.

0 is silent, except for fatal errors
4 is reasonable for general usage
5 and 6 can help to debug connection problems
9 is extremely verbose
HMS increase to 5 to help debug if there is an issue
verb 9

]

And in comcfg.txt make sure VPNDiag is set to 8.

We need to get some kind of error in the logs to resolve this.


#36

One thing I did not notice at first going through the instructions again is you need to make sure some settings are changed in the EasyRSA var file:

Execute the steps shown in the Digital Ocean OpenVPN Setup Step 2 to build the CA. The default names will be used in this app note as shown in the Digital Ocean OpenVPN Setup. The following adjustments must be made to the vars file. The vars file must include the following lines uncommented.

set_var EASYRSA_KEY_SIZE 2048
set_var EASYRSA_NS_SUPPORT “yes”
set_var EASYRSA_NS_COMMENT “Easy-RSA Generated Certificate”

Check to make sure you have these settings in the var file and if not, please update them and re-create the certs.

Kyle


#37

Hi Kyle,

We have holidays till Sunday.I will try on monday and update you.

Thank you in advance


#38

Hi Kyle,

Do you have any immediate contact like skype id or anything else ?

So that we will solve this problem easily.


#39

Hi kyle,

My settings in var file are correct.I already uncommented that lines.

And I change the verb to 9 there.

Check server log file after changing verb 9 from verb 3. Is it correct ?

And then i connect my flexy to VPN Server but it still shows VPN Connection is not configured.

It gives me an error message in real time logging like…Options error: Unrecognized option or missing parameter(s) in /var/run/OpenVPN-qyhtri:1: client (2.0.9)

What can i do to resolve this?

Thank you in advance

Server.log (23 KB)


#40

Hi Kyle, Please check the ewon configurations. Is it correct or not ?

It is still shows VPN Configuration is not connected.

Thank you in advance.

MOVED TO STAFF NOTE (229 KB)


#42

Hi kyle
Is eFive connected with other openvpn compatible client?


#43

Your comcfg file does not point to your hms_client.ovpn file. You need to change this setting in comcfg:

VPNCfgFile:+/usr/hms_client.ovpn

It also appears there is a routing problem where the client cannot reach the server.

I’m not exactly sure what you are asking. The eFive is basically an OpenVPN server with our web interface on top of it. It is for use with the eWON clients such as Cosy and Flexy devices.

I haven’t had a lot of time to go over this. At this current time we don’t officially support using your own OpenVPN server.

Kyle


#44

Hi kyle

I have config this setting VPNCfgFile:+/usr/hms_client.ovpn in my comcfg.txt

But also it shows vpn connection is not configured.


#45

Hi kyle,

I have error like Options error: Unrecognized option or missing parameter(s) in /var/run/OpenVPN-qyhtri:1: client (2.0.9) after config VPNCfgFile:+/usr/hms_client.ovpn in comcfg.txt. How can i solve this ?

How can i solve that routing problem where the client can jot reach the server ?

Thank you in advance