Support - HMS EN2SE-R DF1 stopping


#1

Hola Eduardo,

Sigue la información solicitada, hoy tenemos cerca de 15 módulos instalados en la planta comunicando entre 2 PLC´s AllenBradley (SLC 5/04 y CompactLogix).

Todos los dispositivos funcionan correctamente, sin embargo al momento que se apaga el equipo la subnetwork se pone con el LED 5 en rojo, aunque que siga la transmisión de datos la información no me llega en tiempo real debido a un retraso en la transmisión de datos.

El equipo solo regresa a su estado normal de funcionamiento cuando se le da un start manual en el subnetwork monitor, y el LED 5 se pone verde y la transmisión de datos trabaja sin retrasos.

Te dejo el link donde estuve buscando respuestas, además de la configuración y log.

Joao

HMS_CONFIG.cfg (16 KB)

log.txt (32.8 KB)


#10

Hi,

I have a similar issue, when my device turns off my subnet stops and i can not start the communication automatically. What shoud i change?

thanks


HMS EN2SE-R Time Out
#11

Hello @Joao_Ricardo_N_Morae,

Do you have the control/status word enabled? It sounds like you might have it set to enabled but no startup lock. In this mode all the nodes will start on boot but once they enter an error state you need to reenable them using the control word.

Deryck


#13

The control/status word is disabled.

when i turn off the module, always i have to start the network (Subnework monitor) and i have a lot of troubles cause of that.


#14

Hi, the control/status word is disable, however when the power off i must to start the network (Subnetwork monitor), but i dont know why…


#15

Hello @Joao_Ricardo_N_Morae,

You should not have to start the node from the node monitor unless the control word is on.

If you just power up the device, connect with ACM, then take a log of the serial traffic do you see any Tx traffic?

Can you upload the configuration off of the device and upload that and the log file here for me to take a look at.

Deryck


#16

HMS_CONFIG.cfg (16.0 KB)

My Last configuration…


#17

Hi @Joao_Ricardo_N_Morae,

I see no reason why this configuration would not be starting the transactions automatically. Can you confirm you do not see any Tx traffic in a log started right after the device boots up.

Deryck


#18

That is my log file when the decive boots up (Led 5 Red).log.txt (32.8 KB)


#19

What sould i do? Any suggestion?

Thanks


#20

Hi @Joao_Ricardo_N_Morae,

This log was taken without using the start button from the node monitor?

The logs shows both Tx and Rx traffic and seems to be talking to the serial device. Can you provide a log with the device working correctly so I can compare?

Deryck


#21

Log file (Device working - LED 5 Green).

Actually, there is traffic but when the decive is running with erros (LED 5 red) i dont receive the correct information until i use the start button.log1.txt (31.0 KB)


#22

We have 15 devices installed with the same issue…


#23

Hi @Joao_Ricardo_N_Morae ,

The traffic between the two logs looks roughly the same and I don’t see a difference that would be preventing them from working. Where are you checking for data is it just VIA the node monitor? Do you see data from the PLC tags you create?

What I you can do is enable the control word then use that to enable the nodes.See page 72 of the user guide for details on the control word.

Deryck


#24

I have tried using the control word enabled did not work, is very weird cause if i disconnect the serial cable and reconnect it the subnetwok works very well, but if i have a cycle power the LED 5 turns Red and i do not receive the correct data…is there anyone in Mexico that could help me in loco?

Thanks


#25

Just to be clear, when the device is running with fault after cycle power (Led 5 Red) i still have a link but there is a delay so i do not receive the correct information on time.


#26

Are you enabling the nodes with the control word?

I will reach out to our sales engineers who work in Mexico and see if they would be able to assist.

Deryck


#27

@Joao_Ricardo_N_Morae,

Can you provide further details about where you are located and what distributor your purchase though?

Deryck


#28

Risoul, we are in Coahuila Mexico.


#29

Hello Joao,

As mentioned towards the end of the last conversation, that I merged into this topic, have you tried enabling the control word and toggling the nodes off then on? this involves a few steps in the plc to start the nodes. This should restart the node and get the traffic flowing again.

I am also checking with my colleagues in Sweden to see if they have any input or suggestions.

Regards,
Deryck