Tags not saving?


#1

I created a Modbus tag in my Flexy 205 on FW 13.0. I then imported that to the eWON tag generator spreadsheet and created more tags and exported them to the eWON. When I was done I had 22 tags, none with errors.

When I came in this morning I ran the Talk2M wizard and registered it to an account. When I went to look at my tags they were all completely gone. I had saved my spreadsheet so I went back to it and exported again. This time only 9 of the 22 tags went through. I don’t get any errors from the spreadsheet.

Backup with and without support files attached, as well as my spreadsheet.

eWON Tags.xlsm (45.1 KB)

MOVED TO STAFF NOTE (21.5 KB)

MOVED TO STAFF NOTE (49.5 KB)


#3

This is strange Tom. Have you tried importing multiple times?

I would suggest factory resetting the device and then re-importing them.

Kyle


#5

Yes, I tried importing several times. Often I still got just 9. At one point after deleting I only got 5.

This morning the unit still has all of the tags so hopefully no issues from here on out

Anything unusual in the logs? It looked like the event log didn’t go back very far… The 5th was when I first imported the tags but it only had logs back to the morning of the 6th, after the tags were already missing


#6

The logs only went back to 5th, looks like they were probably overwritten by the dns errors because the unit wasn’t able to connect to internet.

There are errors from the 5th where it was trying to write a tag to a location that already had a tag. Seems like they were actually there but just not showing up for some reason.


#8

I factory reset the device and re-exported my tags to it. They weren’t reading yet, but that’s because the Modbus IOServer wasn’t configured yet and my PLC wasn’t powered on. So I configured that, went and ran the wizards to get it back online, powered up my PLC, and went to look at my tags. No tags showed at all. Gone.

What’s going on here?


#9

So once again I created a single tag, imported to the tag spreadsheet, created more tags, and export to the eWON. Only half the tags showed up.

Once again, I had events saying a tag has already been advised:


#10

I think this is due to updates in firmware 13 that broke the tag generator spreadsheet. See the post from Nolan at the end for how to fix: Where can I find the eWON TAG GENERATOR file


#11

I am using Nolan’s updated spreadsheet.


#12

Hi Tom,

Unfortunately the Tag generator isn’t officially supported and seems to have problems with the new firmware. It’s also constantly flagged and deleted by anti-virus, so the tags will have to be entered directly into the eWON for now until we can come up with a better solution. I’m sorry about that and we will continue to work on it.

Kyle