Talk2M Connection Checker TrustFailure


When I run the Talk2M Connection Checker, I receive the error
“Connection to the Talk2M Access Server failed.”
“Reason of error: TrustFailure”
I thought it was an issue with our corporate Firewall so I tried the connection checker from my home computer where I do not have a firewall running and receive the same error. Can someone please help with this issue. Thank you in Advance.


THe current Talk2m Connection checker software does not work with our current servers. We are working on a new version of the software that will reliably give the correct information.

As of now, the only accurate way to determine VPN capability is by running the Talk2m Wizard.

Thank you for the reply and explanation. So we are having an issue with a Cosy 141 staying connected. It will connect for a minute are being restarted, then disconnect. Then periodically, it will connect on its one for a minute then disconnect. We were using the connection tool to try and troubleshoot, but that is not not an option at this point. Can you help with the connection issue and tell me where the issue might reside? Thank you in Advance.

If you can supply a backup with support files, i can revew the event logs to determine where the error might be.

This can be done by using a local connection, and using ebuddy to extract the backup with support files.

Hi Kevin

Here is the backup with support files .TAR file. Thank you for your help.



So looking through the config, the device isn’t connected to the internet. What is the internet connection method method? (Ethernet, wifi, cellular)

I would ensure the device is connected to the internet before running the VPN wizard.

It is connected with Ethernet. The end user, Ronny, connected it to his laptop to run eBuddy to get the backup files. Not sure if that is why you were not seeing as connected in the logs. When we reboot it, it shows as online in eCatcher for a minute and then disconnects. Im going to see if Ronny can jump in on this tread, since he is the one who has the eWON in his location. I am doing all of this remotely and do not have direct access. Thank You.

Excellent. I would have him double check the DNS addresses they are using. Have them set the device to use standard google DNS such as and

I see a lot of DNS failures in the event logs when the device was connected to the internet.

Hey Kevin, Ronny the technician on site.
Where do I see/set the DNS addresses?

You will set the DNS during the internet Wizard.

If think sthomas just did that remotely. We both working on multiple projects.
He may know more.

Test results:

ok WAN connection
ok UDP connection
ok HTTP direct connection
ok HTTP Proxy connection Operation skipped
ok Read Talk2M config
ok Test VPN connection VPN connection timeout

![Error] FAILED: VPN Stopped for reconfiguration

Yes, that what we got after running the wizard. All connections are good until it tests the VPN. Then it Failed on the VPN.

Please review the following documentation and ensure that the firewall is allowing the VPN connection.

Hi Kevin,

First I want to thank you for all your help today. I found the issue and was able to get it fixed. Hopefully this will help someone else.
The WAN IP port on the Corporate side of the network, was set to DHCP. It was pulling an IP address from the DHCP server on the network. It was getting the IP address of 192.168.xx.30. I found that this IP address was statically assigned to the color printer in the main office. So it was conflicting with the eWON and causing the intermitting connections. So, I excluded 192.168.xx.30 from DHCP for the printer. Then I rebooted the eWON and it pulled a new address of 192.168.xx.95 on the WAN. Then I went into the DHCP server and reserved this address for the eWON. The WAN port on the eWAN is still DHCP, but when it is connected to the corp network, it will always get the same IP address of .95 and that will never be assigned to anything else. Checked the Web interface and the eCatcher software on your laptop and it has been online for the last 20 minutes.
Thanks Again.



I am glad you were able to resolve this issue.

Also thank you for explaining in detail what the root cause was. I will ensure this is noted so that others can find it as well.

1 Like

Good job. Thank you.