TLS 1.0 no longer supported

The MyCSVHistorian no longer works and the error i get is

“The request was aborted: Could not create SSL/TLS secure channel.”

It seems that TLS 1.0 is no longer supported by Talk2M. Can you help me get this working again please.

No, you will need to upgrade. TLS 1.0 is no longer used and has been deprecated by the industry.

I understand that but the MYCSVHISTORIAN was downloaded from HMS and I don’t know how to change it to work with the new TLS. I believe Simon wrote the code.

OK, I didn’t realize it was an HMS software. I will ask if they can update it.

Simon is going to update it ASAP. I’ll let you know when it’s available.

Hi @Lonny,

Simon has updated the program:



I am now getting this error message in the log.

Options and Credentials are imported from config.ini …
Collecting the latest data…
Data received. transactionId = 359316
Tag Lafontaine.SBRAC2_AL_ARREThas no history.
3723 samples written to disk

The remote server returned an error: (400) Bad Request.
DataMailbox Error: at least one parameter must be specified.

Did you make sure these fields are all in the ‘config.ini’ file with your dev ID and token?

DateTimeFormat:MM/dd/yy H:mm:ss zzz

I just tested it and it is working for me.

I still get the same error but some weird data comes in. Its always the same data and it doesn’t delete the data after the import. It also always adds the title. I don’t want to use the title.

Here is my config setup and a copy of the datalog.