Trigger Alarm using PLC Tags


#1

Hello,
I am using a Netbiter EC310 to do remote access into a Compact GuardLogix PLC. I want to also use tags from the PLC to trigger alarms and send an email. How can I do that?


#2

Hello @AMI

You can have the Netbiter send alarm email with it in remote management mode. Please take a look at section 5 of the Argos Admin User Manual for details on setting up a device and alarms.

Deryck


#4

I am aware of sending emails this way. I was wondering how I could do it using tags from my PLC. I can’t seem to find an option for that when setting up my alarms.


#5

#6

How would I use a PLC tag to do this? I can’t seem to find a way to do it while setting up my alarms.


#7

Hi AMI,

The netbiter has support for mobus TCP & RTU along with some ethernet/IP support. For ethernet/IP we support Get_attribute_single, Set_attribute_singe, Read_Tag_Service, and Write_Tag_Service. Typically Get and set attribute singe are not supported by PLC’s and is common on most Ethernet/IP slave devices. Read and Write Tag Service allow for symbolic tags to be accesses and is what we see used with ethernet/IP PLC tags. You will need to ensure your PLC supports these services. Here is a screen shot from the manual.

To configure alarms you will need to setup a template with read tags parameters configured and then add the device to the Netbiter. Once the device is added you can configure Alarms from the template.

Deryck

Also, I am not sure why you were received a message regarding the Cummins 1302 Graphics. If you could send me a screen should or forward the email received to us-support@hms.se I can look into this issue.


#9

The PLC that I’m using has documentation on communicating using Read Tag Service. However, the parameter that I created for this says that the service is not supported. Am I missing something in the communication that I need to set up?


#10

I am not familiar with that error message. Can you send me a screen shot showing the error? It sounds like you might not have the correct template type selected.

Deryck


#11

This is what I get if the conditions aren’t met for the alarm. If they are met, I get a “DS: Unknown Data Failure” message.


#12

HI AMI,

If you are getting this error it is most likely not supported by the plc or the tag you created does not support it. Is it a global level tag? What PLC are you using?

Deryck


#13

I was not using a global tag. I am now, but it still shows that message. I am using a Compact GuardLogix 1769-L33ERMS.


#14

Hi,

I have not been able to find any info regarding your plc that states it supports Read_Tag_Service or Write_Tag_Service. We have determined that the Netbiter is sending the messages and getting a response, but the PLC is responding with an error message. You will need to verify that the tags you have setup for the Netbiter are configured and can be accesses with Write/Read_Tag_Service.

Regards,
Deryck


#16

Hello,

I have had some time to do some research. I found where I had read that my PLC supports these services. The list of services for 1769 Compact Guardlogix is listed in the Logix 5000 Data Access Manual. The most recent one I could find is from Jan. 2019. We are still unsure why the Global Tag is not being read. Do you have any examples where this has been done?

Thank you.


#17

Hello AMI,

I have had this working on a compactlogix PLC (1769-L24ER). I would expect it to be the very similar but I am not sure if the plc being a Guardlogix has any effect on tag access.

What would you be looking to see in an example i can look into getting access to that test PLC again and create a simple program.

Can you upload your template that you are using in Argos for me to take a look at.

Regards,
Deryck


#18

Hello,
According to the Data Access Manual, there should be no difference in tag access between the two. I would like to see some very basic test program that could read a Boolean tag into the Netbiter, as well as the template that you used to read the tag inside the Netbiter. I just want to look at the differences, to see if I can find where I went wrong.

I attached the template I used. I’m just trying to read a Boolean tag named EStop_OK from the PLC.

PLC.xml (415 Bytes)

Thank you.


#19

Hello I was able to set up a quick demo with our plc using your template plus an additional tag.


Here is a copy of the project. All I did was create two controller tags and i was able able to read it.
Testing.ACD (2.0 MB)


#20

Hello,
When I downloaded the file, all of the tags were missing, and the message instruction has lost all of it’s information.

Could you supply me with the message setup information, particularly the information for this window? I think this message instruction is the reason why I couldn’t get the PLC to respond before.

Message_Window


#21

Hello AMI,

You do not use message instructions and no ladder logic is needed for the Netbiter to read tags. You can see from my screenshot above I have added Controller level tags, Netbiter_test & EStop_OK. The Netbiter is reading them directly from the PLC.

Regards,
Deryck


#22

Hello,
I tried adding an EStop_OK to your program when I ran it, and still got the “CIP: Service not supported (0x08)” error code. I also tried it on one of our programs, and got the same response. The Netbiter confirms that it is online, and it is connected correctly.


#23

Hello AMI,

This seems like it could be a seeing on the plc to enable external access of its tags. What is the scope of the tags you are creating? For the Netbiter to access them they need to Controller scoped tags. I found this regarding external access in apdf online. image