Trying to download config to CANopenCM Via USB, Get error message

New project, TiA Portal V15.1
I have configured the S7-1200 module as Node 127, The device I need to exchange data with is Node 10. Config Manager running on windows7 64bit.
Device trying to connect to is Argo-Hytos OpcomII Particle counter.
Any advice appreciated.

Have you tried changing the Node ID in the config to match the device? (10 or x0A)

Hi Thanks for your response.
The node ID of the device that I want to communicate with is factory preset at 10 (x0A) which is what I set in my configuration file. I also set the node ID of the HMS CM CANopen module to the default 127.
I have not yet connected the device or any other devices to the CANoopen connection of the module, was just trying to pre-load the configuration via USB cable.

Further information to previous message. I reviewed the configuration in TiA Portal and set the CM module to 127 to match the config in CM Configuration manager but still unable to download, but now with different error message as per the attached screenshot.

  1. Are you using the CM CANopen as the manager?

  2. Is the PLC set to stop when you are doing the download?

  3. Are you following the steps in Configuration Example in the User Manual?

  4. What is the state of the Status LEDs on the CM CANopen?

Hi Kyle
I am using the cm canopen as the manager and configured as per the info in the user manual with default addesss 127.
I have not tried with the plc in stop mode to transfer the configuration via usb. It has always been in run mode
I have tried to follow all steps as per the config example but using my own system/device node addresses & eds files instead.
I will have to check the light status in the morning and feedback on this.

Thanks again, G

From the manual:

Here is a link to some demos that might be helpful to you:

Thank you again Kyle for the information.
I put the s7-1200 in to stop and tried again with the transfer of the config file from configuration manager using the USB cable. It at least this time started to transfer the config, but again gives another error message as shown in the attached image.
Maybe I should give up ? :slightly_smiling_face:

Can you please share your config file (.copprj)?

Canbus1200_OpcomII.copprj (3.4 KB)

Thanks Kyle, as requested

Thanks, but I’m unable to open it.

I think we will need to put you in touch with the IXXAT team, who can take a look at this and possible look at it with you over Teamviewer. Since it looks like you are in the UK, you will need to first create a case by going to It looks like an account has already been created for you there, so if you haven’t logged in before, you may just need to do a password reset.

I will email my colleague in Germany who is the expert with this device, so he will be expecting the case and has the background. Please let me know if you have any questions about that. I’m sure with their help you will be successful with this device.


Thank you for your patience Kyle.
I have attached the eds file that I received from the device manufacturer that I am trying to communicate with.
Maybe this will help to see if you can create a successful configuration using this file or if there is a problem with the EDS that is causing the issues I have.
I just want to be able to read all possible data from this device using canopen. I am sure with this device it is also possible to send data from plc → device via canbus too but these options have never been available after I import the EDS.

Thanks again.CANopen_AH_OpCom_II_-_2.02.15_2015.05.21.eds (15.6 KB)

Christian says:

The download fails because the configuration of the RPDOs of the CM CANopen contains a dummy object that is not supported by the CM CANopen:

this problem can be solved by using the default configuration of TPDO1 and TPDO2 of OpcomII that transfer the selected objects.

tab: Application Objects

=> right click on Node-ID: 10

=> Remove All of Device


=> right click on Node-ID: 10

=> Select Default Mappings of Device

=> mark TPDO1 and TPDO2

Hi @gazg,

Christian analyzed the EDS file and found:

a) the mapping of TPDO 4 is wrong:

3 mapped objects that transfer 10 data bytes
but maximum 8 data bytes can be transmitted

b) the default transmission type of the TPDOs is missing:

low limit and high limit are missing
if synchronous transmission types are supported:
object 1005h is missing

Long story short, it’s no good. Here is a revised EDS that you can try. There is no guarantee that it will work. If it does not you will have to contact the manufacturer to get a new one.

CANopen_AH_OpCom_II_-_2.02.15_2015.05.21 - HMS-formally corrected.eds (15.8 KB)

Thank you Kyle, Sorry for the delay, been working away this week. I will try my best to try this new eds tomorrow and feedback how we get on. Many thanks for your efforts.

Thanks for the update!